Initial packaging (#2319894)
parent
3162429671
commit
3697abb52a
@ -0,0 +1 @@
|
||||
/zlib-rs-0.3.1.crate
|
@ -0,0 +1,107 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate zlib-rs
|
||||
|
||||
Name: rust-zlib-rs
|
||||
Version: 0.3.1
|
||||
Release: %autorelease
|
||||
Summary: Memory-safe zlib implementation written in rust
|
||||
|
||||
License: Zlib
|
||||
URL: https://crates.io/crates/zlib-rs
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop dependencies and internal-only features for fuzz-testing
|
||||
Patch: zlib-rs-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A memory-safe zlib implementation written in rust.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+c-allocator-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+c-allocator-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "c-allocator" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+c-allocator-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rust-allocator-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rust-allocator-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rust-allocator" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rust-allocator-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (zlib-rs-0.3.1.crate) = 83b68185ade43ab27ff9a213a89c6ed23c9044b90402494251b4026ce7647128fac90321103e20069ebdd4a6e08b828c1aa66352e19d2056ec80edfe3d46e4c2
|
@ -0,0 +1,36 @@
|
||||
--- zlib-rs-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zlib-rs-0.3.1/Cargo.toml 2024-10-19T09:51:09.355690+00:00
|
||||
@@ -30,23 +30,6 @@
|
||||
name = "zlib_rs"
|
||||
path = "src/lib.rs"
|
||||
|
||||
-[dependencies.arbitrary]
|
||||
-version = "1.0"
|
||||
-features = ["derive"]
|
||||
-optional = true
|
||||
-
|
||||
-[dependencies.libz-sys]
|
||||
-version = "1.1.19"
|
||||
-features = ["zlib-ng"]
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
-[dependencies.quickcheck]
|
||||
-version = "1.0.3"
|
||||
-features = []
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[dev-dependencies.crc32fast]
|
||||
version = "1.3.2"
|
||||
|
||||
@@ -56,9 +39,6 @@
|
||||
default-features = false
|
||||
|
||||
[features]
|
||||
-ZLIB_DEBUG = []
|
||||
-__internal-fuzz = ["arbitrary"]
|
||||
-__internal-test = ["quickcheck"]
|
||||
c-allocator = []
|
||||
default = [
|
||||
"std",
|
Loading…
Reference in new issue