parent
337b098f0b
commit
5067b77c32
@ -0,0 +1 @@
|
|||||||
|
/zerocopy-0.6.5.crate
|
@ -0,0 +1,123 @@
|
|||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate zerocopy
|
||||||
|
|
||||||
|
Name: rust-zerocopy0.6
|
||||||
|
Version: 0.6.5
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Utilities for zero-copy parsing and serialization
|
||||||
|
|
||||||
|
License: BSD-2-Clause
|
||||||
|
URL: https://crates.io/crates/zerocopy
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * relax trybuild dev-dependency from =1.0.80 to ^1.0.80
|
||||||
|
Patch: zerocopy-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Utilities for zero-copy parsing and serialization.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||||
|
%doc %{crate_instdir}/INTERNAL.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+__internal_use_only_features_that_work_on_stable-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+__internal_use_only_features_that_work_on_stable-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "__internal_use_only_features_that_work_on_stable" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+__internal_use_only_features_that_work_on_stable-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+simd-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+simd-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "simd" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+simd-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+simd-nightly-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+simd-nightly-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "simd-nightly" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+simd-nightly-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# * integration tests can only be run in upstream CI
|
||||||
|
%cargo_test -- --lib
|
||||||
|
%cargo_test -- --doc
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,3 @@
|
|||||||
|
[tests]
|
||||||
|
run = ["lib", "doc"]
|
||||||
|
comments = ["integration tests can only be run in upstream CI"]
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (zerocopy-0.6.5.crate) = 3b8d96ce0ad8c9449a7937d3ca0aafa4450640372941b184b88c157eff14fc638d26806aa54ff875f253a19433ac382d6b0184171aa9c8d5112c20c53c4464ba
|
@ -0,0 +1,11 @@
|
|||||||
|
--- zerocopy-0.6.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ zerocopy-0.6.5/Cargo.toml 2023-10-27T10:37:29.585137+00:00
|
||||||
|
@@ -45,7 +45,7 @@
|
||||||
|
version = "1.1"
|
||||||
|
|
||||||
|
[dev-dependencies.trybuild]
|
||||||
|
-version = "=1.0.80"
|
||||||
|
+version = "1.0.80"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
__internal_use_only_features_that_work_on_stable = [
|
Loading…
Reference in new issue