commit
0ca7c8e78d
@ -0,0 +1 @@
|
|||||||
|
SOURCES/yansi-term-0.1.2.crate
|
@ -0,0 +1 @@
|
|||||||
|
c68133b1a77003c7ac947992d99690621be13f69 SOURCES/yansi-term-0.1.2.crate
|
@ -0,0 +1,12 @@
|
|||||||
|
--- yansi-term-0.1.2/Cargo.toml 2020-05-31T12:48:56+00:00
|
||||||
|
+++ yansi-term-0.1.2/Cargo.toml 2023-08-17T15:27:40.846610+00:00
|
||||||
|
@@ -36,9 +36,6 @@
|
||||||
|
|
||||||
|
[features]
|
||||||
|
derive_serde_style = ["serde"]
|
||||||
|
-[target."cfg(target_os=\"windows\")".dependencies.winapi]
|
||||||
|
-version = "0.3.4"
|
||||||
|
-features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "processenv"]
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "actively-developed"
|
||||||
|
|
@ -0,0 +1,116 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 3;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate yansi-term
|
||||||
|
|
||||||
|
Name: rust-yansi-term
|
||||||
|
Version: 0.1.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Library for ANSI terminal colours and styles (bold, underline)
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/yansi-term
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: yansi-term-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Library for ANSI terminal colours and styles (bold, underline).}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENCE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+derive_serde_style-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+derive_serde_style-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "derive_serde_style" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+derive_serde_style-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.2-3
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.2-1
|
||||||
|
- Initial import (#2232626)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue