Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent e5933e069e
commit aee88ebc5c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,30 +1,31 @@
# Generated by rust2rpm # Generated by rust2rpm 10
# * Tests are run in infrastructure %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate yaml-rust %global crate yaml-rust
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.3 Version: 0.4.3
Release: 1%{?dist} Release: 2%{?dist}
Summary: YAML 1.2 parser for rust Summary: YAML 1.2 parser for rust
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/yaml-rust URL: https://crates.io/crates/yaml-rust
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Update quickcheck to 0.8, https://github.com/chyh1990/yaml-rust/pull/131
Patch0: yaml-rust-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(linked-hash-map/default) >= 0.0.9 with crate(linked-hash-map/default) < 0.6.0)
%if %{with check}
BuildRequires: (crate(quickcheck/default) >= 0.7.0 with crate(quickcheck/default) < 0.8.0)
%endif
%global _description \ %global _description %{expand:
The missing YAML 1.2 parser for rust. Missing YAML 1.2 parser for rust.}
%description %{_description} %description %{_description}
@ -60,6 +61,9 @@ which use "default" feature of "%{crate}" crate.
chmod -x tests/specs/cpp2rust.rb chmod -x tests/specs/cpp2rust.rb
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -72,6 +76,9 @@ chmod -x tests/specs/cpp2rust.rb
%endif %endif
%changelog %changelog
* Thu Jun 20 09:25:38 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-2
- Regenerate
* Thu Mar 07 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-1 * Thu Mar 07 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-1
- Update to 0.4.3 - Update to 0.4.3

@ -0,0 +1,8 @@
--- yaml-rust-0.4.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ yaml-rust-0.4.3/Cargo.toml 2019-06-20T07:27:09.096903+00:00
@@ -23,4 +23,4 @@
[dependencies.linked-hash-map]
version = ">=0.0.9, <0.6"
[dev-dependencies.quickcheck]
-version = "0.7"
+version = "0.8"
Loading…
Cancel
Save