Update to version 0.1.7; Fixes RHBZ#2094065

epel9
Fabio Valentini 3 years ago
parent 9d9cef1cba
commit fb8f68964d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/xz2-0.1.4.crate /xz2-0.1.4.crate
/xz2-0.1.5.crate /xz2-0.1.5.crate
/xz2-0.1.6.crate /xz2-0.1.6.crate
/xz2-0.1.7.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm # Generated by rust2rpm 21
%bcond_with check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate xz2 %global crate xz2
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.6 Version: 0.1.7
Release: %autorelease Release: %autorelease
Summary: Rust bindings to liblzma Summary: Rust bindings to liblzma
@ -13,22 +13,17 @@ Summary: Rust bindings to liblzma
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/xz2 URL: https://crates.io/crates/xz2
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * drop feature for statically linking liblzma
Patch0: xz2-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
BuildRequires: (crate(futures/default) >= 0.1.0 with crate(futures/default) < 0.2.0)
BuildRequires: (crate(lzma-sys/default) >= 0.1.11 with crate(lzma-sys/default) < 0.2.0)
BuildRequires: (crate(tokio-io/default) >= 0.1.0 with crate(tokio-io/default) < 0.2.0)
%if %{with check}
BuildRequires: (crate(quickcheck/default) >= 0.7.0 with crate(quickcheck/default) < 0.8.0)
BuildRequires: (crate(rand/default) >= 0.5.0 with crate(rand/default) < 0.6.0)
BuildRequires: (crate(tokio-core/default) >= 0.1.0 with crate(tokio-core/default) < 0.2.0)
%endif
%global _description \ %global _description %{expand:
Rust bindings to liblzma providing Read/Write streams as well as low-level\ Rust bindings to liblzma providing Read/Write streams as well as low-level in-
in-memory encoding/decoding. memory encoding/decoding.}
%description %{_description} %description %{_description}
@ -38,13 +33,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -52,11 +48,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-devel %package -n %{name}+futures-devel
Summary: %{summary} Summary: %{summary}
@ -64,11 +60,11 @@ BuildArch: noarch
%description -n %{name}+futures-devel %{_description} %description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "futures" feature of "%{crate}" crate. use the "futures" feature of the "%{crate}" crate.
%files -n %{name}+futures-devel %files -n %{name}+futures-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel %package -n %{name}+tokio-devel
Summary: %{summary} Summary: %{summary}
@ -76,11 +72,11 @@ BuildArch: noarch
%description -n %{name}+tokio-devel %{_description} %description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "tokio" feature of "%{crate}" crate. use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel %files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-io-devel %package -n %{name}+tokio-io-devel
Summary: %{summary} Summary: %{summary}
@ -88,18 +84,19 @@ BuildArch: noarch
%description -n %{name}+tokio-io-devel %{_description} %description -n %{name}+tokio-io-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "tokio-io" feature of "%{crate}" crate. use the "tokio-io" feature of the "%{crate}" crate.
%files -n %{name}+tokio-io-devel %files -n %{name}+tokio-io-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
# Test relies on relative paths, moreover those files are not packaged anywhere
sed -i -e "/fn standard_files/i #[ignore]" tests/xz.rs
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -108,7 +105,8 @@ sed -i -e "/fn standard_files/i #[ignore]" tests/xz.rs
%if %{with check} %if %{with check}
%check %check
%cargo_test # * skip a test that relies on files which are not included in published crates
%cargo_test -- -- --skip standard_files
%endif %endif
%changelog %changelog

@ -1 +1 @@
SHA512 (xz2-0.1.6.crate) = c0880b2bbf890e962b27efda6c513d1626332ff400dd08a9126a6e1d1375e0d0e3bf243b10df78e2397b611d0365b6526d96974c4ff332bb81edba71b6ebc811 SHA512 (xz2-0.1.7.crate) = 9969ae958b157f3d49708bd00640e57fe7c3826add2871575bdac03e6064aabd28392e3062bfbb833752df374195c50b19dc6b6c08ac41455c492213fb91fc74

@ -0,0 +1,10 @@
--- xz2-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
+++ xz2-0.1.7/Cargo.toml 2022-07-16T12:16:30.646078+00:00
@@ -60,7 +60,6 @@
version = "0.1.17"
[features]
-static = ["lzma-sys/static"]
tokio = [
"tokio-io",
"futures",
Loading…
Cancel
Save