import rust-xxhash-c-sys-0.8.4-1.el9

i9ce changed/i9ce/rust-xxhash-c-sys-0.8.4-1.el9
Arkady L. Shane 1 year ago
commit 2e52de9a07
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,27 @@
From cfd35c97f0cfe947d8d31ea89613b2f66489d34c Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 29 Apr 2022 12:16:10 +0200
Subject: [PATCH] build and link against shared xxhash library
---
build.rs | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/build.rs b/build.rs
index 15ceda2..fa9739e 100644
--- a/build.rs
+++ b/build.rs
@@ -1,9 +1,3 @@
fn main() {
- let mut cc = cc::Build::new();
-
- cc.include("src/c/");
- cc.file("src/c/xxhash.c");
- cc.warnings(false);
-
- cc.compile("xxhash");
+ pkg_config::Config::new().atleast_version("0.8.1").probe("libxxhash").unwrap();
}
--
2.36.0

Binary file not shown.

@ -0,0 +1,19 @@
--- xxhash-c-sys-0.8.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ xxhash-c-sys-0.8.4/Cargo.toml 2023-08-07T22:17:30.216566+00:00
@@ -16,8 +16,6 @@
authors = ["Douman <douman@gmx.se>"]
include = [
"**/*.rs",
- "**/*.c",
- "**/*.h",
"Cargo.toml",
"README.md",
"LICENSE",
@@ -37,5 +35,5 @@
version = "0.2"
default-features = false
-[build-dependencies.cc]
-version = "1"
+[build-dependencies.pkg-config]
+version = "0.3"

@ -0,0 +1,106 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate xxhash-c-sys
Name: rust-xxhash-c-sys
Version: 0.8.4
Release: %autorelease
Summary: Bindings to xxhash
License: BSL-1.0
URL: https://crates.io/crates/xxhash-c-sys
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * build and link against shared xxhash library
Patch: xxhash-c-sys-fix-metadata.diff
Patch: 0001-build-and-link-against-shared-xxhash-library.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Bindings to xxhash.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
Requires: pkgconfig(libxxhash) >= 0.8.1
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# remove bundled copy of xxhash
rm -r src/c
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
echo 'pkgconfig(libxxhash) >= 0.8.1'
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip a test that hardcodes a check against the system xxhash version
%cargo_test -- -- --skip assert_version
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.4-1
- Rebuilt for MSVSphere 9.3
* Mon Aug 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-1
- Update to version 0.8.4; Fixes RHBZ#2228013
* Thu Jul 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.3-5
- Skip a test that hardcodes a check against the system xxhash version
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu May 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.3-1
- Initial import (#2080245)
Loading…
Cancel
Save