commit
4cd8174067
@ -0,0 +1 @@
|
|||||||
|
SOURCES/wmidi-4.0.10.crate
|
@ -0,0 +1 @@
|
|||||||
|
da20ec1a0693771c328a1f8274be270f6b011d91 SOURCES/wmidi-4.0.10.crate
|
@ -0,0 +1,5 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only criterion dev-dependency",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,17 @@
|
|||||||
|
--- wmidi-4.0.10/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ wmidi-4.0.10/Cargo.toml 2024-06-18T13:02:36.236028+00:00
|
||||||
|
@@ -29,14 +29,7 @@
|
||||||
|
[lib]
|
||||||
|
bench = false
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "bench"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
[dependencies]
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = ["std"]
|
@ -0,0 +1,111 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate wmidi
|
||||||
|
|
||||||
|
Name: rust-wmidi
|
||||||
|
Version: 4.0.10
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Midi parsing library
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/wmidi
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency
|
||||||
|
Patch: wmidi-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Midi parsing library.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.0.10-2
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 18 2024 Fabio Valentini <decathorpe@gmail.com> - 4.0.10-1
|
||||||
|
- Update to version 4.0.10; Fixes RHBZ#2255134
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 30 2023 Fabio Valentini <decathorpe@gmail.com> - 4.0.8-1
|
||||||
|
- Update to version 4.0.8; Fixes RHBZ#2235923
|
||||||
|
|
||||||
|
* Sun Jul 23 2023 Davide Cavalca <dcavalca@fedoraproject.org> - 4.0.6-1
|
||||||
|
- Initial import; Fixes: RHBZ#2224755
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue