import rust-winnow0.4-0.4.11-1.el9

i9ce changed/i9ce/rust-winnow0.4-0.4.11-1.el9
Arkady L. Shane 1 year ago
commit e8c4662675
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

Binary file not shown.

@ -0,0 +1,142 @@
--- winnow-0.4.11/Cargo.toml 1970-01-01T00:00:01+00:00
+++ winnow-0.4.11/Cargo.toml 2023-09-13T20:29:21.509385+00:00
@@ -83,117 +83,10 @@
[Unreleased]: https://github.com/winnow-rs/winnow/compare/{{tag_name}}...HEAD"""
search = "<!-- next-url -->"
-[profile.bench]
-lto = true
-codegen-units = 1
-debug = 2
-
-[[example]]
-name = "arithmetic"
-test = true
-required-features = ["alloc"]
-
-[[example]]
-name = "css"
-test = true
-required-features = ["alloc"]
-
-[[example]]
-name = "custom_error"
-test = true
-required-features = ["alloc"]
-
-[[example]]
-name = "http"
-required-features = ["alloc"]
-
-[[example]]
-name = "ini"
-test = true
-required-features = ["std"]
-
-[[example]]
-name = "json"
-test = true
-required-features = ["std"]
-
-[[example]]
-name = "ndjson"
-test = true
-required-features = ["std"]
-
-[[example]]
-name = "json_iterator"
-required-features = ["std"]
-
-[[example]]
-name = "iterator"
-
-[[example]]
-name = "s_expression"
-required-features = ["alloc"]
-
-[[example]]
-name = "string"
-required-features = ["alloc"]
-
-[[bench]]
-name = "arithmetic"
-path = "examples/arithmetic/bench.rs"
-harness = false
-
-[[bench]]
-name = "contains_token"
-harness = false
-
-[[bench]]
-name = "number"
-harness = false
-
-[[bench]]
-name = "http"
-path = "examples/http/bench.rs"
-harness = false
-required-features = ["alloc"]
-
-[[bench]]
-name = "ini"
-path = "examples/ini/bench.rs"
-harness = false
-required-features = ["std"]
-
-[[bench]]
-name = "json"
-path = "examples/json/bench.rs"
-harness = false
-required-features = ["std"]
-
-[dependencies.anstyle]
-version = "0.3.5"
-optional = true
-
-[dependencies.anstyle-stream]
-version = "0.2.2"
-optional = true
-
-[dependencies.is-terminal]
-version = "0.4.7"
-optional = true
-
[dependencies.memchr]
version = "2.5"
optional = true
default-features = false
-
-[dependencies.terminal_size]
-version = "0.2.6"
-optional = true
-
-[dev-dependencies.circular]
-version = "0.3.0"
-
-[dev-dependencies.criterion]
-version = "0.3.6"
[dev-dependencies.doc-comment]
version = "0.3"
@@ -207,21 +100,8 @@
[dev-dependencies.proptest]
version = "1.2.0"
-[dev-dependencies.snapbox]
-version = "0.4.11"
-features = ["examples"]
-
-[dev-dependencies.term-transcript]
-version = "0.2.0"
-
[features]
alloc = []
-debug = [
- "dep:anstyle",
- "dep:is-terminal",
- "dep:terminal_size",
- "dep:anstyle-stream",
-]
default = ["std"]
simd = ["dep:memchr"]
std = [

@ -0,0 +1,136 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate winnow
Name: rust-winnow0.4
Version: 0.4.11
Release: %autorelease
Summary: Byte-oriented, zero-copy, parser combinators library
License: MIT
URL: https://crates.io/crates/winnow
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove references to benchmark and example binaries from Cargo.toml
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop dev-dependencies which are only needed for example binaries
# * drop unused "debug" feature with outdated dependencies
Patch: winnow-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A byte-oriented, zero-copy, parser combinators library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+simd-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+simd-devel %{_description}
This package contains library source intended for building other packages which
use the "simd" feature of the "%{crate}" crate.
%files -n %{name}+simd-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-doc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-doc-devel %{_description}
This package contains library source intended for building other packages which
use the "unstable-doc" feature of the "%{crate}" crate.
%files -n %{name}+unstable-doc-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.11-1
- Rebuilt for MSVSphere 9.3
* Thu Sep 14 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.11-1
- Initial import (winnow 0.4 compat package)
Loading…
Cancel
Save