parent
8552a970b9
commit
814ff21421
@ -0,0 +1 @@
|
|||||||
|
/wild-2.0.1.crate
|
@ -0,0 +1,75 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
# * Tests are run in infrastructure
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate wild
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 2.0.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Glob (wildcard) expanded command-line arguments
|
||||||
|
|
||||||
|
# https://gitlab.com/kornelski/wild/issues/2
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/wild
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
Patch0: wild-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: (crate(glob/default) >= 0.2.11 with crate(glob/default) < 0.3.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
Glob (wildcard) expanded command-line arguments.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.1-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (wild-2.0.1.crate) = 001f83176ab74b1ebff70fa63bcb93d66aee8eb7519d917af3ba894a208b2346da38ff278b26b11affde90755530ea707918c9476e3b0c72951d23bcb1677ec9
|
@ -0,0 +1,11 @@
|
|||||||
|
--- wild-2.0.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ wild-2.0.1/Cargo.toml 2018-11-04T17:23:27.957851+01:00
|
||||||
|
@@ -24,8 +24,6 @@
|
||||||
|
repository = "https://gitlab.com/kornelski/wild"
|
||||||
|
[dev-dependencies.glob]
|
||||||
|
version = "0.2.11"
|
||||||
|
-[target."cfg(windows)".dependencies.glob]
|
||||||
|
-version = "0.2.11"
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "pornel/wild"
|
||||||
|
|
Loading…
Reference in new issue