Update to version 5.0.0

epel9 imports/e9/rust-which-5.0.0-1.el9
Fabio Valentini 1 year ago
parent 8eda07584e
commit 8de3009b7f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -13,3 +13,4 @@
/which-4.3.0.crate /which-4.3.0.crate
/which-4.4.0.crate /which-4.4.0.crate
/which-4.4.2.crate /which-4.4.2.crate
/which-5.0.0.crate

@ -1,21 +1,24 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate which %global crate which
Name: rust-which Name: rust-which
Version: 4.4.2 Version: 5.0.0
Release: %autorelease Release: %autorelease
Summary: Rust equivalent of Unix command "which" Summary: Rust equivalent of Unix command "which"
License: MIT License: MIT
URL: https://crates.io/crates/which URL: https://crates.io/crates/which
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: which-fix-metadata-auto.diff Patch: which-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * relax dependency on the "regex" crate from =1.9.6 to ^1.9.6
Patch: which-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
A Rust equivalent of Unix command "which". Locate installed executable A Rust equivalent of Unix command "which". Locate installed executable
@ -63,7 +66,7 @@ use the "regex" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (which-4.4.2.crate) = 2d12aa1d4c2dbc140e39c8f15bd4ee1eeb8e8de71bcdf579479ef4be860fb0839eaf4cdb818addba242d50420f6e08acaf2bfc979a889e092c83644819246fd5 SHA512 (which-5.0.0.crate) = cf2b6ec2f156f4d6af0bdb8b468965784000158bc7ab8f76fa1b1d7a1a2c732a7392c8ea09d3cc79259411e3ed7ed2d448a6aa94fe7c2fae077186086b0f826a

@ -1,8 +1,15 @@
--- which-4.4.2/Cargo.toml 1970-01-01T00:00:01+00:00 --- which-5.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ which-4.4.2/Cargo.toml 2023-09-17T14:56:27.053730+00:00 +++ which-5.0.0/Cargo.toml 2024-01-19T17:09:47.141117+00:00
@@ -55,5 +55,3 @@ @@ -55,12 +55,3 @@
[target."cfg(any(windows, unix, target_os = \"redox\"))".dependencies.home] [target."cfg(any(windows, unix, target_os = \"redox\"))".dependencies.home]
version = "0.5.5" version = "0.5.5"
-[target."cfg(windows)".dependencies.once_cell] -[target."cfg(windows)".dependencies.once_cell]
-version = "1" -version = "1"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.48"
-features = [
- "Win32_Storage_FileSystem",
- "Win32_Foundation",
-]

@ -0,0 +1,11 @@
--- which-5.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ which-5.0.0/Cargo.toml 2024-01-19T17:09:56.591155+00:00
@@ -38,7 +38,7 @@
version = "1.6.1"
[dependencies.regex]
-version = "= 1.9.6"
+version = "1.9.6"
optional = true
[dependencies.rustix]
Loading…
Cancel
Save