Update pulldown-cmark to 0.7

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 39a040416e
commit 01025ee00a
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,32 @@
From 4f9abc6a9c2f4918a445f8217a07849eb42f4bca Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Sat, 22 Feb 2020 19:11:32 +0100
Subject: [PATCH] chore: Update pulldown-cmark to 0.7
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
---
src/markdown_deps.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/markdown_deps.rs b/src/markdown_deps.rs
index a557c1c..01c45b3 100644
--- a/src/markdown_deps.rs
+++ b/src/markdown_deps.rs
@@ -1,4 +1,4 @@
-use pulldown_cmark::{Event, Parser, Tag};
+use pulldown_cmark::{CodeBlockKind, Event, Parser, Tag};
use semver_parser::range::parse as parse_request;
use semver_parser::range::VersionReq;
use semver_parser::version::parse as parse_version;
@@ -63,7 +63,7 @@ fn find_toml_blocks(text: &str) -> Vec<CodeBlock<'_>> {
let mut code_blocks = Vec::new();
for (event, range) in parser.into_offset_iter() {
match event {
- Event::Start(Tag::CodeBlock(ref lang)) if is_toml_block(lang) => {
+ Event::Start(Tag::CodeBlock(CodeBlockKind::Fenced(ref lang))) if is_toml_block(lang) => {
let line_count = text[..range.start].lines().count();
let code_block = &text[range];
let start = 1 + code_block.find('\n').unwrap_or(0);
--
2.25.0

@ -1,4 +1,4 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
@ -6,7 +6,7 @@
Name: rust-%{crate}
Version: 0.8.1
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Simple crate for ensuring that version numbers in README files are updated when the crate version changes
# Upstream license specification: MIT
@ -14,10 +14,11 @@ License: MIT
URL: https://crates.io/crates/version-sync
Source: %{crates_source}
# Initial patched metadata
# - Bump pulldown-cmark to 0.6, https://github.com/mgeisler/version-sync/pull/79
# - Bump pulldown-cmark to 0.7
Patch0: version-sync-fix-metadata.diff
# * Fix tests with toml 0.5.3+, https://github.com/mgeisler/version-sync/commit/33dc77fda8c5d993abee4e6c31c7526408877003
Patch0001: 0001-markdown_deps-handle-test-output-from-toml-0.5.3.patch
Patch0002: 0001-chore-Update-pulldown-cmark-to-0.7.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -44,7 +45,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -56,7 +57,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -77,6 +78,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Sat Feb 22 19:27:14 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.1-7
- Update pulldown-cmark to 0.7
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1,11 +1,11 @@
--- version-sync-0.8.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ version-sync-0.8.1/Cargo.toml 2019-09-13T17:03:49.667142+00:00
+++ version-sync-0.8.1/Cargo.toml 2020-02-22T18:27:14.733899+00:00
@@ -31,7 +31,7 @@
features = ["span-locations"]
[dependencies.pulldown-cmark]
-version = "0.4"
+version = "0.6"
+version = "0.7"
default-features = false
[dependencies.regex]

Loading…
Cancel
Save