commit
981a084911
@ -0,0 +1 @@
|
|||||||
|
SOURCES/v_frame-0.3.7.crate
|
@ -0,0 +1 @@
|
|||||||
|
86b4e05409b353051248cc4f4a6744aaec1c167d SOURCES/v_frame-0.3.7.crate
|
@ -0,0 +1,24 @@
|
|||||||
|
From e8c304aa3a7bff59d8a5cd7d69c3df6cd6704410 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Mon, 15 Jan 2024 16:44:33 +0100
|
||||||
|
Subject: [PATCH] remove noop profiling macros
|
||||||
|
|
||||||
|
---
|
||||||
|
src/plane.rs | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/plane.rs b/src/plane.rs
|
||||||
|
index 66cfa07..0c5fe73 100644
|
||||||
|
--- a/src/plane.rs
|
||||||
|
+++ b/src/plane.rs
|
||||||
|
@@ -621,7 +621,6 @@ impl<T: Pixel> Plane<T> {
|
||||||
|
/// # Panics
|
||||||
|
///
|
||||||
|
/// - If the current plane's width and height are not at least `SCALE` times the `in_plane`'s
|
||||||
|
- #[profiling::function(downscale_in_place)]
|
||||||
|
pub fn downscale_in_place<const SCALE: usize>(&self, in_plane: &mut Plane<T>) {
|
||||||
|
let stride = in_plane.cfg.stride;
|
||||||
|
let width = in_plane.cfg.width;
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -0,0 +1,44 @@
|
|||||||
|
--- v_frame-0.3.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ v_frame-0.3.7/Cargo.toml 2024-01-15T15:41:08.434659+00:00
|
||||||
|
@@ -19,10 +19,6 @@
|
||||||
|
license = "BSD-2-Clause"
|
||||||
|
repository = "https://github.com/rust-av/v_frame"
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "bench"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "1.0"
|
||||||
|
|
||||||
|
@@ -35,30 +31,10 @@
|
||||||
|
[dependencies.num-traits]
|
||||||
|
version = "0.2"
|
||||||
|
|
||||||
|
-[dependencies.profiling]
|
||||||
|
-version = "1"
|
||||||
|
-
|
||||||
|
[dependencies.serde]
|
||||||
|
version = "1.0"
|
||||||
|
features = ["derive"]
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[dependencies.tracing]
|
||||||
|
-version = "0.1.40"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dependencies.wasm-bindgen]
|
||||||
|
-version = "0.2.63"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.5"
|
||||||
|
-features = ["html_reports"]
|
||||||
|
-
|
||||||
|
[features]
|
||||||
|
serialize = ["serde"]
|
||||||
|
-tracing = [
|
||||||
|
- "profiling/profile-with-tracing",
|
||||||
|
- "dep:tracing",
|
||||||
|
-]
|
||||||
|
-wasm = ["wasm-bindgen"]
|
@ -0,0 +1,158 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate v_frame
|
||||||
|
|
||||||
|
Name: rust-v_frame
|
||||||
|
Version: 0.3.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Video Frame data structures, originally part of rav1e
|
||||||
|
|
||||||
|
License: BSD-2-Clause
|
||||||
|
URL: https://crates.io/crates/v_frame
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, no-op tracing/profiling support
|
||||||
|
# * drop WASM-specific wasm-bindgen dependency and wasm feature
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency
|
||||||
|
Patch: v_frame-fix-metadata.diff
|
||||||
|
Patch: 0001-remove-noop-profiling-macros.patch
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Video Frame data structures, originally part of rav1e.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serialize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serialize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serialize" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serialize-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.3.7-2
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 03 2024 Fabio Valentini <decathorpe@gmail.com> - 0.3.7-1
|
||||||
|
- Update to version 0.3.7; Fixes RHBZ#2220656
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.4-1
|
||||||
|
- Update to version 0.3.4; Fixes RHBZ#2132091
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 08 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.5-4
|
||||||
|
- Remove unused dependencies on wasm-bindgen and hawktracer
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Nov 14 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.5-1
|
||||||
|
- Update to 0.2.5 Close: rhbz#1991571
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 7 17:23:55 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.1-1
|
||||||
|
- Update to 0.2.1
|
||||||
|
|
||||||
|
* Mon Mar 29 16:26:18 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.0-1
|
||||||
|
- Update to 0.2.0
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 10 08:55:10 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.0-1
|
||||||
|
- Initial package
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue