Update to version 1.2.0; Fixes RHBZ#2133131

epel9
Fabio Valentini 2 years ago
parent 8b53bae30f
commit d625fa1be5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/uuid-0.8.2.crate
/uuid-1.1.1.crate
/uuid-1.1.2.crate
/uuid-1.2.0.crate

@ -5,7 +5,7 @@
%global crate uuid
Name: rust-uuid
Version: 1.1.2
Version: 1.2.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -14,6 +14,9 @@ URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * relax arbitrary dependency from =1.1.3 to ^1.1.3
Patch: uuid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -66,88 +69,76 @@ use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fast-rng-devel %{_description}
This package contains library source intended for building other packages which
use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md5-devel
%package -n %{name}+atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md5-devel %{_description}
%description -n %{name}+atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "md5" feature of the "%{crate}" crate.
use the "atomic" feature of the "%{crate}" crate.
%files -n %{name}+md5-devel
%files -n %{name}+atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+private_atomic-devel
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+private_atomic-devel %{_description}
%description -n %{name}+fast-rng-devel %{_description}
This package contains library source intended for building other packages which
use the "private_atomic" feature of the "%{crate}" crate.
use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+private_atomic-devel
%files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+private_getrandom-devel
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+private_getrandom-devel %{_description}
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "private_getrandom" feature of the "%{crate}" crate.
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+private_getrandom-devel
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+private_md-5-devel
%package -n %{name}+md-5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+private_md-5-devel %{_description}
%description -n %{name}+md-5-devel %{_description}
This package contains library source intended for building other packages which
use the "private_md-5" feature of the "%{crate}" crate.
use the "md-5" feature of the "%{crate}" crate.
%files -n %{name}+private_md-5-devel
%files -n %{name}+md-5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+private_rand-devel
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+private_rand-devel %{_description}
%description -n %{name}+md5-devel %{_description}
This package contains library source intended for building other packages which
use the "private_rand" feature of the "%{crate}" crate.
use the "md5" feature of the "%{crate}" crate.
%files -n %{name}+private_rand-devel
%files -n %{name}+md5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+private_sha1_smol-devel
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+private_sha1_smol-devel %{_description}
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "private_sha1_smol" feature of the "%{crate}" crate.
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+private_sha1_smol-devel
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-devel
@ -186,6 +177,18 @@ use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1_smol-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1_smol-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1_smol" feature of the "%{crate}" crate.
%files -n %{name}+sha1_smol-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slog-devel
Summary: %{summary}
BuildArch: noarch
@ -258,6 +261,54 @@ use the "v5" feature of the "%{crate}" crate.
%files -n %{name}+v5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v6-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v6-devel %{_description}
This package contains library source intended for building other packages which
use the "v6" feature of the "%{crate}" crate.
%files -n %{name}+v6-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v7-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v7-devel %{_description}
This package contains library source intended for building other packages which
use the "v7" feature of the "%{crate}" crate.
%files -n %{name}+v7-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v8-devel %{_description}
This package contains library source intended for building other packages which
use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm-bindgen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wasm-bindgen-devel %{_description}
This package contains library source intended for building other packages which
use the "wasm-bindgen" feature of the "%{crate}" crate.
%files -n %{name}+wasm-bindgen-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

@ -1,6 +1,6 @@
[DEFAULT]
unwanted-features =
private_uuid-macro-internal
zerocopy
js
macro-diagnostics
uuid-macro-internal

@ -1 +1 @@
SHA512 (uuid-1.1.2.crate) = de1d1019d224c248e19cbf8a8539dc55937b23f74c5a8b11a445f8b7c155d35caa2001d6c710f4a4a8c034446162ef32c0e3be9f3d43631477c6f3d350acf7d0
SHA512 (uuid-1.2.0.crate) = 123e7987c6847e14c001a92d92e1f49ab7961130edf66c0db9aed94e20e3146fb01111414abcd627688de7b01618d399f0ffaf97781aa183f60c8e75fa6cf4e0

@ -1,22 +1,27 @@
--- uuid-1.1.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.1.2/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -146,20 +146,6 @@
v4 = ["rng"]
v5 = ["sha1"]
--- uuid-1.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -153,7 +153,6 @@
"rand",
]
js = [
- "wasm-bindgen",
"getrandom",
"getrandom/js",
]
@@ -173,17 +172,6 @@
]
v8 = []
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-lib]
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
-version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(windows)".dev-dependencies.winapi]
-version = "0.3"
-features = [
- "combaseapi",
- "impl-default",
-]
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.42.0"
-features = ["Win32_System_Com"]
-
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"

@ -0,0 +1,11 @@
--- uuid-1.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.2.0/Cargo.toml 2022-10-08T14:28:24.038588+00:00
@@ -74,7 +74,7 @@
]
[dependencies.arbitrary]
-version = "=1.1.3"
+version = "1.1.3"
optional = true
[dependencies.atomic]
Loading…
Cancel
Save