Update to 0.6.4

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 744fcf7ccc
commit afd4533908
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,2 +1,3 @@
/uuid-0.5.1.crate
/uuid-0.6.3.crate
/uuid-0.6.4.crate

@ -5,7 +5,7 @@
%global crate uuid
Name: rust-%{crate}
Version: 0.6.3
Version: 0.6.4
Release: 1%{?dist}
Summary: Library to generate and parse UUIDs
@ -14,20 +14,21 @@ URL: https://crates.io/crates/uuid
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Drop slog dependency until packaged
Patch0: uuid-0.6.3-fix-metadata.diff
Patch0: uuid-0.6.4-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
BuildRequires: ((crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0) with crate(byteorder/i128))
BuildRequires: (crate(cfg-if) >= 0.1.2 with crate(cfg-if) < 0.2.0)
BuildRequires: (crate(md5) >= 0.3.0 with crate(md5) < 0.4.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.16 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde) >= 1.0.56 with crate(serde) < 2.0.0)
BuildRequires: (crate(sha1) >= 0.6.0 with crate(sha1) < 0.7.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(serde_test) >= 1.0.19 with crate(serde_test) < 2.0.0)
BuildRequires: (crate(serde_test) >= 1.0.56 with crate(serde_test) < 2.0.0)
%endif
%description
@ -65,6 +66,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/bors.toml
%changelog
* Thu May 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-1
- Update to 0.6.4
* Thu Apr 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-1
- Update to 0.6.3

@ -1 +1 @@
SHA512 (uuid-0.6.3.crate) = de6fe3a2fe5d5ecf1b2cb6858358b813d93f7c92ef76b1395710dc4a635987e51e5a474d9844e1a28920ac0703177460f78aaacd46dd5ddad92f2e8fa84beca2
SHA512 (uuid-0.6.4.crate) = 6d7b4cb07268a9b1eedc821eafea1bcf5af6c14f8c95563f803f916113794533a4066bd64a8f152a04db5a6595e92b88bd6f56b9b6c78d488b7fd2b5c8905b7f

@ -1,12 +0,0 @@
--- uuid-0.6.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ uuid-0.6.3/Cargo.toml 2018-04-26T09:14:24.299700+02:00
@@ -42,9 +42,6 @@
version = "0.6"
optional = true
-[dependencies.slog]
-version = "2"
-optional = true
[dev-dependencies.serde_test]
version = "1.0.19"

@ -0,0 +1,12 @@
--- uuid-0.6.4/Cargo.toml 1970-01-01T01:00:00+01:00
+++ uuid-0.6.4/Cargo.toml 2018-05-24T09:59:00.062822+02:00
@@ -52,9 +52,6 @@
version = "0.6"
optional = true
-[dependencies.slog]
-version = "2"
-optional = true
[dev-dependencies.serde_test]
version = "1.0.56"
Loading…
Cancel
Save