Update to 0.6.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 9c3fea0c3a
commit 744fcf7ccc
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/uuid-0.5.1.crate
/uuid-0.6.3.crate

@ -5,27 +5,30 @@
%global crate uuid
Name: rust-%{crate}
Version: 0.5.1
Release: 5%{?dist}
Version: 0.6.3
Release: 1%{?dist}
Summary: Library to generate and parse UUIDs
License: MIT or ASL 2.0
URL: https://crates.io/crates/uuid
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4, https://github.com/rust-lang-nursery/uuid/pull/109
# * Bump sha1 to 0.4, https://github.com/rust-lang-nursery/uuid/pull/110
Patch0: uuid-0.5.1-fix-metadata.diff
# * Drop slog dependency until packaged
Patch0: uuid-0.6.3-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
BuildRequires: (crate(md5) >= 0.3.0 with crate(md5) < 0.4.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(rustc-serialize) >= 0.3.0 with crate(rustc-serialize) < 0.4.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(sha1) >= 0.4.0 with crate(sha1) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.16 with crate(serde) < 2.0.0)
BuildRequires: (crate(sha1) >= 0.6.0 with crate(sha1) < 0.7.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(serde_test) >= 1.0.19 with crate(serde_test) < 2.0.0)
%endif
%description
%{summary}.
@ -59,8 +62,12 @@ which use %{crate} from crates.io.
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/bors.toml
%changelog
* Thu Apr 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-1
- Update to 0.6.3
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (uuid-0.5.1.crate) = 6865a85dd53f7455f741de558127371e85e47c8c4ed6dfccdd90fc7ec71dc66d370af551bf9463a36399440b28bce329114cd27afc87f4072f1e6e2d9ebf9116
SHA512 (uuid-0.6.3.crate) = de6fe3a2fe5d5ecf1b2cb6858358b813d93f7c92ef76b1395710dc4a635987e51e5a474d9844e1a28920ac0703177460f78aaacd46dd5ddad92f2e8fa84beca2

@ -1,13 +0,0 @@
--- uuid-0.5.1/Cargo.toml 2017-06-30T08:40:30+02:00
+++ uuid-0.5.1/Cargo.toml 2017-12-31T18:42:15.121307+01:00
@@ -18,8 +18,8 @@
[dependencies]
rustc-serialize = { version = "0.3", optional = true }
serde = { version = "1.0", optional = true }
-rand = { version = "0.3", optional = true }
-sha1 = { version = "0.2", optional = true }
+rand = { version = "0.4", optional = true }
+sha1 = { version = "0.4", optional = true }
md5 = { version = "0.3", optional = true }
[features]

@ -0,0 +1,12 @@
--- uuid-0.6.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ uuid-0.6.3/Cargo.toml 2018-04-26T09:14:24.299700+02:00
@@ -42,9 +42,6 @@
version = "0.6"
optional = true
-[dependencies.slog]
-version = "2"
-optional = true
[dev-dependencies.serde_test]
version = "1.0.19"
Loading…
Cancel
Save