Update to version 1.7.0; Fixes RHBZ#2259067

epel10
Fabio Valentini 1 year ago
parent 3f92d68dba
commit a0703b58d5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -22,3 +22,4 @@
/uuid-1.4.1.crate /uuid-1.4.1.crate
/uuid-1.5.0.crate /uuid-1.5.0.crate
/uuid-1.6.1.crate /uuid-1.6.1.crate
/uuid-1.7.0.crate

@ -5,7 +5,7 @@
%global crate uuid %global crate uuid
Name: rust-uuid Name: rust-uuid
Version: 1.6.1 Version: 1.7.0
Release: %autorelease Release: %autorelease
Summary: Library to generate and parse UUIDs Summary: Library to generate and parse UUIDs
@ -37,13 +37,9 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT %license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md %doc %{crate_instdir}/README.md
%doc %{crate_instdir}/SECURITY.md
%{crate_instdir}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -106,30 +102,6 @@ use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+fast-rng-devel %files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md-5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md-5-devel %{_description}
This package contains library source intended for building other packages which
use the "md-5" feature of the "%{crate}" crate.
%files -n %{name}+md-5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md5-devel %package -n %{name}+md5-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -142,18 +114,6 @@ use the "md5" feature of the "%{crate}" crate.
%files -n %{name}+md5-devel %files -n %{name}+md5-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-devel %package -n %{name}+rng-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -190,18 +150,6 @@ use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel %files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1_smol-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1_smol-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1_smol" feature of the "%{crate}" crate.
%files -n %{name}+sha1_smol-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slog-devel %package -n %{name}+slog-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1 +1 @@
SHA512 (uuid-1.6.1.crate) = b9f3dbad176b3640b4b943d127ac8fcd0938e7bc750430626cc603efdcf5faf479f8de7940d64ed1b5b6e6378b42a1aaf3c1e791ee59b9db9394409261cf3c55 SHA512 (uuid-1.7.0.crate) = 2ea704d082b725d98717d772e1af84fe743929ee32658ebeb111c6fa2395ff5f44558b7e375087617f91c6f7bc242f2db96e80a631071722de6fe15af845e856

@ -1,6 +1,6 @@
--- uuid-1.6.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- uuid-1.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.6.1/Cargo.toml 2023-11-25T12:07:02.306458+00:00 +++ uuid-1.7.0/Cargo.toml 2024-01-30T12:39:54.882093+00:00
@@ -184,17 +184,6 @@ @@ -192,12 +192,6 @@
] ]
v8 = [] v8 = []
@ -9,16 +9,11 @@
- -
-[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen] -[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen]
-version = "0.2" -version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.48.0"
-features = ["Win32_System_Com"]
- -
[badges.is-it-maintained-issue-resolution] [badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid" repository = "uuid-rs/uuid"
@@ -203,3 +192,4 @@ @@ -206,3 +200,4 @@
[badges.maintenance] [badges.maintenance]
status = "actively-developed" status = "actively-developed"

@ -1,29 +1,33 @@
--- uuid-1.6.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- uuid-1.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.6.1/Cargo.toml 2023-11-25T12:07:30.448571+00:00 +++ uuid-1.7.0/Cargo.toml 2024-01-30T12:40:26.586271+00:00
@@ -85,10 +85,6 @@ @@ -89,16 +89,6 @@
optional = true
default-features = false default-features = false
package = "atomic"
-[dependencies.borsh] -[dependencies.borsh]
-version = "0.10.3" -version = "1"
-optional = true
-default-features = false
-
-[dependencies.borsh-derive]
-version = "1"
-optional = true -optional = true
-default-features = false
- -
[dependencies.bytemuck] [dependencies.bytemuck]
version = "1.14.0" version = "1.14.0"
features = ["derive"] features = ["derive"]
@@ -125,20 +121,6 @@ @@ -131,18 +121,6 @@
version = "2" version = "2"
optional = true optional = true
-[dependencies.uuid-macro-internal] -[dependencies.uuid-macro-internal]
-version = "1.6.1" -version = "1.7.0"
-optional = true -optional = true
-package = "uuid-macro-internal"
- -
-[dependencies.wasm-bindgen] -[dependencies.wasm-bindgen]
-version = "0.2" -version = "0.2"
-optional = true -optional = true
-package = "wasm-bindgen"
- -
-[dependencies.zerocopy] -[dependencies.zerocopy]
-version = "0.6" -version = "0.6"
@ -32,16 +36,24 @@
[dev-dependencies.bincode] [dev-dependencies.bincode]
version = "1.0" version = "1.0"
@@ -163,12 +145,6 @@ @@ -163,20 +141,11 @@
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng", "rng",
"rand", "dep:rand",
] ]
-js = [ -js = [
- "wasm-bindgen", - "dep:wasm-bindgen",
- "getrandom", - "getrandom?/js",
- "getrandom/js",
-] -]
-macro-diagnostics = ["uuid-macro-internal"] -macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["md-5"] md5 = ["dep:md-5"]
rng = ["getrandom"] rng = ["dep:getrandom"]
sha1 = ["sha1_smol"] sha1 = ["dep:sha1_smol"]

Loading…
Cancel
Save