import rust-uuid-1.13.2-1.el10

i10ce changed/i10ce/rust-uuid-1.13.2-1.el10
MSVSphere Packaging Team 2 days ago
parent f54bcb5eab
commit 7390a85410
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/uuid-1.11.0.crate
SOURCES/uuid-1.13.2.crate

@ -1 +1 @@
90bc36254934ce1df6710fdd9d4c8dc2d16c6a50 SOURCES/uuid-1.11.0.crate
e3a19ef3915956f3c258d44fdb3f9d188cb78029 SOURCES/uuid-1.13.2.crate

@ -1,31 +1,56 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:19:57.658776+00:00
@@ -178,7 +178,6 @@
--- uuid-1.13.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.13.2/Cargo.toml 2025-02-18T06:22:27.957442+00:00
@@ -106,8 +106,6 @@
"dep:rand",
]
js = [
- "dep:wasm-bindgen",
"getrandom?/js",
- "dep:js-sys",
]
macro-diagnostics = ["dep:uuid-macro-internal"]
@@ -194,16 +193,6 @@
v7 = ["rng"]
v8 = []
md5 = ["dep:md-5"]
@@ -115,14 +113,10 @@
rng-getrandom = [
"rng",
"dep:getrandom",
- "uuid-rng-internal-lib",
- "uuid-rng-internal-lib/getrandom",
]
rng-rand = [
"rng",
"dep:rand",
- "uuid-rng-internal-lib",
- "uuid-rng-internal-lib/rand",
]
sha1 = ["dep:sha1_smol"]
std = []
@@ -208,25 +202,6 @@
[dev-dependencies.trybuild]
version = "1.0.52"
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.uuid-rng-internal-lib]
-version = "1.13.2"
-optional = true
-package = "uuid-rng-internal"
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen]
-version = "0.2"
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target.'cfg(target = "wasm32-unknown-unknown")'.dev-dependencies.wasm-bindgen]
-version = "0.2"
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown", target_feature = "atomics"))'.dependencies.js-sys]
-version = "0.3"
-optional = true
-
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -217,3 +206,4 @@
[target.'cfg(not(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown")))'.dependencies.getrandom]
version = "0.3"
optional = true
@@ -239,3 +214,4 @@
level = "allow"
priority = 0
check-cfg = ["cfg(uuid_unstable)"]

@ -1,6 +1,6 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:20:19.529890+00:00
@@ -53,7 +53,6 @@
--- uuid-1.13.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.13.2/Cargo.toml 2025-02-18T06:23:00.155576+00:00
@@ -54,7 +54,6 @@
"serde",
"arbitrary",
"slog",
@ -8,7 +8,26 @@
"v1",
"v3",
"v4",
@@ -97,16 +96,6 @@
@@ -96,18 +95,11 @@
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
rng-getrandom = [
@@ -141,16 +133,6 @@
optional = true
default-features = false
@ -25,39 +44,19 @@
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -139,15 +128,6 @@
version = "2"
optional = true
@@ -173,15 +155,6 @@
[dependencies.slog]
version = "2"
-optional = true
-
-[dependencies.uuid-macro-internal]
-version = "1.11.0"
-version = "1.13.2"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.8"
-features = ["derive"]
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -168,19 +148,11 @@
optional = true
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
- "getrandom?/js",
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
sha1 = ["dep:sha1_smol"]
[dev-dependencies.bincode]

@ -8,14 +8,14 @@
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.11.0
Version: 1.13.2
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -137,6 +137,30 @@ use the "rng" feature of the "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "rng-getrandom" feature of the "%{crate}" crate.
%files -n %{name}+rng-getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rng-rand" feature of the "%{crate}" crate.
%files -n %{name}+rng-rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -288,10 +312,16 @@ use the "v8" feature of the "%{crate}" crate.
%endif
%changelog
## START: Generated by rpmautospec
* Tue Feb 18 2025 Marc-André Lureau <marcandre.lureau@redhat.com> - 1.13.2-1
- Update to version 1.13.2; Fixes RHBZ#2336864
* Sun Jan 19 2025 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.11.0-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sun Oct 20 2024 Fabio Valentini <decathorpe@gmail.com> - 1.11.0-1
- Update to version 1.11.0; Fixes RHBZ#2319073

Loading…
Cancel
Save