import rust-uuid-1.11.0-1.el10

i10ce changed/i10ce/rust-uuid-1.11.0-1.el10
MSVSphere Packaging Team 2 months ago
commit f54bcb5eab
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/uuid-1.11.0.crate

@ -0,0 +1 @@
90bc36254934ce1df6710fdd9d4c8dc2d16c6a50 SOURCES/uuid-1.11.0.crate

@ -0,0 +1,8 @@
[package]
cargo-toml-patch-comments = [
"drop unused optional dependency for borsh support",
"drop unused optional dependency for zerocopy support",
"drop WASM-specific features and dependencies",
"drop internal-only features",
]

@ -0,0 +1,32 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:19:57.658776+00:00
@@ -178,7 +178,6 @@
"dep:rand",
]
js = [
- "dep:wasm-bindgen",
"getrandom?/js",
]
macro-diagnostics = ["dep:uuid-macro-internal"]
@@ -194,16 +193,6 @@
v7 = ["rng"]
v8 = []
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target.'cfg(target = "wasm32-unknown-unknown")'.dev-dependencies.wasm-bindgen]
-version = "0.2"
-
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -217,3 +206,4 @@
level = "allow"
priority = 0
check-cfg = ["cfg(uuid_unstable)"]
+

@ -0,0 +1,63 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:20:19.529890+00:00
@@ -53,7 +53,6 @@
"serde",
"arbitrary",
"slog",
- "borsh",
"v1",
"v3",
"v4",
@@ -97,16 +96,6 @@
optional = true
default-features = false
-[dependencies.borsh]
-version = "1"
-optional = true
-default-features = false
-
-[dependencies.borsh-derive]
-version = "1"
-optional = true
-default-features = false
-
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -139,15 +128,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.11.0"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.8"
-features = ["derive"]
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -168,19 +148,11 @@
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
- "getrandom?/js",
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
sha1 = ["dep:sha1_smol"]

@ -0,0 +1,456 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.11.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support
# * drop unused optional dependency for zerocopy support
# * drop WASM-specific features and dependencies
# * drop internal-only features
Patch: uuid-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library to generate and parse UUIDs.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "atomic" feature of the "%{crate}" crate.
%files -n %{name}+atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fast-rng-devel %{_description}
This package contains library source intended for building other packages which
use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md5-devel %{_description}
This package contains library source intended for building other packages which
use the "md5" feature of the "%{crate}" crate.
%files -n %{name}+md5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-devel %{_description}
This package contains library source intended for building other packages which
use the "rng" feature of the "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slog-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+slog-devel %{_description}
This package contains library source intended for building other packages which
use the "slog" feature of the "%{crate}" crate.
%files -n %{name}+slog-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v1-devel %{_description}
This package contains library source intended for building other packages which
use the "v1" feature of the "%{crate}" crate.
%files -n %{name}+v1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v3-devel %{_description}
This package contains library source intended for building other packages which
use the "v3" feature of the "%{crate}" crate.
%files -n %{name}+v3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v4-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v4-devel %{_description}
This package contains library source intended for building other packages which
use the "v4" feature of the "%{crate}" crate.
%files -n %{name}+v4-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v5-devel %{_description}
This package contains library source intended for building other packages which
use the "v5" feature of the "%{crate}" crate.
%files -n %{name}+v5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v6-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v6-devel %{_description}
This package contains library source intended for building other packages which
use the "v6" feature of the "%{crate}" crate.
%files -n %{name}+v6-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v7-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v7-devel %{_description}
This package contains library source intended for building other packages which
use the "v7" feature of the "%{crate}" crate.
%files -n %{name}+v7-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v8-devel %{_description}
This package contains library source intended for building other packages which
use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.11.0-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sun Oct 20 2024 Fabio Valentini <decathorpe@gmail.com> - 1.11.0-1
- Update to version 1.11.0; Fixes RHBZ#2319073
* Wed Jul 31 2024 Michel Lind <salimma@fedoraproject.org> - 1.10.0-1
- Update to version 1.10.0; Fixes RHBZ#2296419
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Sat Jul 06 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 1.9.1-1
- Update to 1.9.1 (close RHBZ#2294052)
* Mon Jun 24 2024 Fabio Valentini <decathorpe@gmail.com> - 1.9.0-1
- Update to version 1.9.0; Fixes RHBZ#2293884
* Tue Mar 19 2024 Fabio Valentini <decathorpe@gmail.com> - 1.8.0-1
- Update to version 1.8.0; Fixes RHBZ#2270213
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 1.7.0-1
- Update to version 1.7.0; Fixes RHBZ#2259067
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Nov 25 2023 Fabio Valentini <decathorpe@gmail.com> - 1.6.1-1
- Update to version 1.6.1; Fixes RHBZ#2250575
* Thu Oct 19 2023 Fabio Valentini <decathorpe@gmail.com> - 1.5.0-1
- Update to version 1.5.0; Fixes RHBZ#2244855
* Sat Jul 29 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.1-1
- Update to version 1.4.1; Fixes RHBZ#2223255
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jul 15 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.0-1
- Update to version 1.4.0; Fixes RHBZ#2217791
* Fri Jun 23 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.4-1
- Update to version 1.3.4; Fixes RHBZ#2214494
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.3-1
- Update to version 1.3.3; Fixes RHBZ#2203814
* Sun Apr 30 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.2-1
- Update to version 1.3.2; Fixes RHBZ#2192075
* Fri Apr 14 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.1-1
- Update to version 1.3.1; Fixes RHBZ#2185419
* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-1
- Update to version 1.3.0; Fixes RHBZ#2166236
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Dec 10 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.2-1
- Update to version 1.2.2; Fixes RHBZ#2142704
* Tue Oct 11 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.1-1
- Update to version 1.2.1; Fixes RHBZ#2133232
* Sat Oct 08 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.0-1
- Update to version 1.2.0; Fixes RHBZ#2133131
* Mon Aug 08 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.2-1
- Update to version 1.1.2; Fixes RHBZ#2095908
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 06 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
- Update to version 1.1.1; Fixes RHBZ#2076870
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Jan 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
- Update to version 0.8.2.
- Fixes RHBZ#1914753
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 0.8.1-2
- Bump to md5 0.7
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 0.8.1-1
- Update to 0.8.1
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Jun 22 10:18:57 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-2
- Regenerate
* Fri Mar 29 15:50:41 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-1
- Update to 0.7.4
* Mon Mar 25 08:29:16 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.3-1
- Update to 0.7.3
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.2-3
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Jan 29 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.2-1
- Update to 0.7.2
* Tue Dec 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-3
- Bump rand, md5 to 0.6
* Sat Dec 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-2
- Run tests in infrastructure
* Tue Nov 20 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Update to 0.7.1
* Fri Nov 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.5-3
- Adapt to new packaging
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri May 25 2018 Josh Stone <jistone@redhat.com> - 0.6.5-1
- Update to 0.6.5
* Thu May 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-1
- Update to 0.6.4
* Thu Apr 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-1
- Update to 0.6.3
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-4
- Rebuild for rust-packaging v5
* Sun Jan 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-3
- Add implicit cargo features
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-2
- Bump rand to 0.4
- Bump sha1 to 0.4
* Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save