Update to version 1.13.2; Fixes RHBZ#2336864

epel10 imports/epel10/rust-uuid-1.13.2-1.el10
Marc-André Lureau 1 week ago committed by Fabio Valentini
parent 796ad1255b
commit 0a285a8aa5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -28,3 +28,5 @@
/uuid-1.9.1.crate
/uuid-1.10.0.crate
/uuid-1.11.0.crate
/uuid-1.13.1.crate
/uuid-1.13.2.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.11.0
Version: 1.13.2
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -127,6 +127,30 @@ use the "rng" feature of the "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "rng-getrandom" feature of the "%{crate}" crate.
%files -n %{name}+rng-getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rng-rand" feature of the "%{crate}" crate.
%files -n %{name}+rng-rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (uuid-1.11.0.crate) = 0cd1b95fc2247bf4e627de6abb41e332ebaf39e5720640e52b9f235f7a0e2d451e7a486efdabb616ce00e47832d21919611683d0e6a71c86a86f290940cfda32
SHA512 (uuid-1.13.2.crate) = 0c4dcd22ce2ee24fe31c64670a26ded7a6cfced7fb862b61a6835d929a2c20dc065ff5dba4efa9853234dd1c972ba4b496252af407e157f2cf4103dbf489def1

@ -1,31 +1,56 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:19:57.658776+00:00
@@ -178,7 +178,6 @@
--- uuid-1.13.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.13.2/Cargo.toml 2025-02-18T06:22:27.957442+00:00
@@ -106,8 +106,6 @@
"dep:rand",
]
js = [
- "dep:wasm-bindgen",
"getrandom?/js",
- "dep:js-sys",
]
macro-diagnostics = ["dep:uuid-macro-internal"]
@@ -194,16 +193,6 @@
v7 = ["rng"]
v8 = []
md5 = ["dep:md-5"]
@@ -115,14 +113,10 @@
rng-getrandom = [
"rng",
"dep:getrandom",
- "uuid-rng-internal-lib",
- "uuid-rng-internal-lib/getrandom",
]
rng-rand = [
"rng",
"dep:rand",
- "uuid-rng-internal-lib",
- "uuid-rng-internal-lib/rand",
]
sha1 = ["dep:sha1_smol"]
std = []
@@ -208,25 +202,6 @@
[dev-dependencies.trybuild]
version = "1.0.52"
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.uuid-rng-internal-lib]
-version = "1.13.2"
-optional = true
-package = "uuid-rng-internal"
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen]
-version = "0.2"
-
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target.'cfg(target = "wasm32-unknown-unknown")'.dev-dependencies.wasm-bindgen]
-version = "0.2"
-[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown", target_feature = "atomics"))'.dependencies.js-sys]
-version = "0.3"
-optional = true
-
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -217,3 +206,4 @@
[target.'cfg(not(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown")))'.dependencies.getrandom]
version = "0.3"
optional = true
@@ -239,3 +214,4 @@
level = "allow"
priority = 0
check-cfg = ["cfg(uuid_unstable)"]

@ -1,6 +1,6 @@
--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:20:19.529890+00:00
@@ -53,7 +53,6 @@
--- uuid-1.13.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.13.2/Cargo.toml 2025-02-18T06:23:00.155576+00:00
@@ -54,7 +54,6 @@
"serde",
"arbitrary",
"slog",
@ -8,7 +8,26 @@
"v1",
"v3",
"v4",
@@ -97,16 +96,6 @@
@@ -96,18 +95,11 @@
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
rng-getrandom = [
@@ -141,16 +133,6 @@
optional = true
default-features = false
@ -25,39 +44,19 @@
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -139,15 +128,6 @@
version = "2"
optional = true
@@ -173,15 +155,6 @@
[dependencies.slog]
version = "2"
-optional = true
-
-[dependencies.uuid-macro-internal]
-version = "1.11.0"
-version = "1.13.2"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.8"
-features = ["derive"]
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -168,19 +148,11 @@
optional = true
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
- "getrandom?/js",
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
sha1 = ["dep:sha1_smol"]
[dev-dependencies.bincode]

Loading…
Cancel
Save