You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
63 lines
1.1 KiB
63 lines
1.1 KiB
--- uuid-1.13.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ uuid-1.13.2/Cargo.toml 2025-02-18T06:23:00.155576+00:00
|
|
@@ -54,7 +54,6 @@
|
|
"serde",
|
|
"arbitrary",
|
|
"slog",
|
|
- "borsh",
|
|
"v1",
|
|
"v3",
|
|
"v4",
|
|
@@ -96,18 +95,11 @@
|
|
|
|
[features]
|
|
atomic = ["dep:atomic"]
|
|
-borsh = [
|
|
- "dep:borsh",
|
|
- "dep:borsh-derive",
|
|
-]
|
|
default = ["std"]
|
|
fast-rng = [
|
|
"rng",
|
|
"dep:rand",
|
|
]
|
|
-js = [
|
|
-]
|
|
-macro-diagnostics = ["dep:uuid-macro-internal"]
|
|
md5 = ["dep:md-5"]
|
|
rng = ["dep:getrandom"]
|
|
rng-getrandom = [
|
|
@@ -141,16 +133,6 @@
|
|
optional = true
|
|
default-features = false
|
|
|
|
-[dependencies.borsh]
|
|
-version = "1"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
-[dependencies.borsh-derive]
|
|
-version = "1"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
[dependencies.bytemuck]
|
|
version = "1.14.0"
|
|
features = ["derive"]
|
|
@@ -173,15 +155,6 @@
|
|
|
|
[dependencies.slog]
|
|
version = "2"
|
|
-optional = true
|
|
-
|
|
-[dependencies.uuid-macro-internal]
|
|
-version = "1.13.2"
|
|
-optional = true
|
|
-
|
|
-[dependencies.zerocopy]
|
|
-version = "0.8"
|
|
-features = ["derive"]
|
|
optional = true
|
|
|
|
[dev-dependencies.bincode]
|