commit
460666128f
@ -0,0 +1 @@
|
|||||||
|
SOURCES/utf8-width-0.1.7.crate
|
@ -0,0 +1 @@
|
|||||||
|
3d924f6a67577f088ffbb87a046e62b122cf844b SOURCES/utf8-width-0.1.7.crate
|
@ -0,0 +1,6 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Determine the width of a UTF-8 character by providing its first byte"
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only bencher dev-dependency",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,15 @@
|
|||||||
|
--- utf8-width-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ utf8-width-0.1.7/Cargo.toml 2024-09-29T16:12:57.252893+00:00
|
||||||
|
@@ -37,12 +37,3 @@
|
||||||
|
]
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/magiclen/utf8-width"
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "bench"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
-[dependencies]
|
||||||
|
-
|
||||||
|
-[dev-dependencies.bencher]
|
||||||
|
-version = "0.1.5"
|
@ -0,0 +1,128 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 4;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate utf8-width
|
||||||
|
|
||||||
|
Name: rust-utf8-width
|
||||||
|
Version: 0.1.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Determine the width of a UTF-8 character by providing its first byte
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/utf8-width
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only bencher dev-dependency
|
||||||
|
Patch: utf8-width-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
To determine the width of a UTF-8 character by providing its first byte.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.7-4
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sun Sep 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.1.7-4
|
||||||
|
- Drop unused, benchmark-only bencher dev-dependency
|
||||||
|
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Nov 25 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.7-1
|
||||||
|
- Update to version 0.1.7; Fixes RHBZ#2250697
|
||||||
|
|
||||||
|
* Mon Aug 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.6-5
|
||||||
|
- Regenerate with rust2rpm v24
|
||||||
|
|
||||||
|
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 21 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.6-1
|
||||||
|
- Update to version 0.1.6; Fixes RHBZ#2065899
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.5-1
|
||||||
|
- Update to version 0.1.5.
|
||||||
|
- Fixes RHBZ#1952631
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 30 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.4-1
|
||||||
|
- Initial package
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue