drop optional serde feature that has missing dependencies

epel9
Fabio Valentini 4 years ago
parent 3608db1897
commit d0f3dad57b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,4 +1,4 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 15
%bcond_with check
%global debug_package %{nil}
@ -6,7 +6,7 @@
Name: rust-%{crate}1
Version: 1.7.2
Release: 3%{?dist}
Release: 4%{?dist}
Summary: URL library for Rust, based on the WHATWG URL Standard
# Upstream license specification: MIT/Apache-2.0
@ -15,6 +15,7 @@ URL: https://crates.io/crates/url
Source: %{crates_source}
# Initial patched metadata
# * Exclude CI files, https://github.com/servo/rust-url/pull/467
# * drop optional + unused serde feature (serde < 1 no longer available)
Patch0: url-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -41,7 +42,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md UPGRADING.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -53,7 +54,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+encoding-devel
Summary: %{summary}
@ -65,7 +66,7 @@ This package contains library source intended for building other packages
which use "encoding" feature of "%{crate}" crate.
%files -n %{name}+encoding-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+heap_size-devel
Summary: %{summary}
@ -77,7 +78,7 @@ This package contains library source intended for building other packages
which use "heap_size" feature of "%{crate}" crate.
%files -n %{name}+heap_size-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+heapsize-devel
Summary: %{summary}
@ -89,7 +90,7 @@ This package contains library source intended for building other packages
which use "heapsize" feature of "%{crate}" crate.
%files -n %{name}+heapsize-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+query_encoding-devel
Summary: %{summary}
@ -101,7 +102,7 @@ This package contains library source intended for building other packages
which use "query_encoding" feature of "%{crate}" crate.
%files -n %{name}+query_encoding-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc-serialize-devel
Summary: %{summary}
@ -113,19 +114,7 @@ This package contains library source intended for building other packages
which use "rustc-serialize" feature of "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -146,6 +135,9 @@ which use "serde" feature of "%{crate}" crate.
%endif
%changelog
* Sun Nov 08 2020 Fabio Valentini <decathorpe@gmail.com> - 1.7.2-4
- Drop optional serde feature that has missing dependencies.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1,5 +1,5 @@
--- url-1.7.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ url-1.7.2/Cargo.toml 2019-08-25T06:47:13.777099+00:00
+++ url-1.7.2/Cargo.toml 2020-11-08T19:39:28.387877+00:00
@@ -21,6 +21,7 @@
categories = ["parser-implementations", "web-programming", "encoding"]
license = "MIT/Apache-2.0"
@ -8,3 +8,13 @@
[package.metadata.docs.rs]
features = ["query_encoding"]
@@ -58,9 +59,6 @@
version = "0.3"
optional = true
-[dependencies.serde]
-version = ">=0.6.1, <0.9"
-optional = true
[dev-dependencies.bencher]
version = "0.1"

Loading…
Cancel
Save