import rust-url1-1.7.2-14.el9.el9

i9ce changed/i9ce/rust-url1-1.7.2-14.el9
MSVSphere Packaging Team 1 year ago
parent 2d97d89766
commit 63b305f17f

@ -0,0 +1,7 @@
[package]
summary = "URL library for Rust, based on the WHATWG URL Standard"
[tests]
run = ["none"]
comments = ["outdated dev-dependencies: serde_json ^0.6.1"]

@ -1,14 +1,25 @@
--- url-1.7.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ url-1.7.2/Cargo.toml 2020-11-08T19:39:28.387877+00:00
@@ -21,6 +21,7 @@
+++ url-1.7.2/Cargo.toml 2024-01-19T19:11:15.829242+00:00
@@ -21,6 +21,8 @@
categories = ["parser-implementations", "web-programming", "encoding"]
license = "MIT/Apache-2.0"
repository = "https://github.com/servo/rust-url"
+exclude = ["/docs/*", "/.travis.yml", "/appveyor.yml"]
+
[package.metadata.docs.rs]
features = ["query_encoding"]
@@ -58,9 +59,6 @@
@@ -37,9 +39,6 @@
[[bench]]
name = "parse_url"
harness = false
-[dependencies.encoding]
-version = "0.2"
-optional = true
[dependencies.heapsize]
version = ">=0.4.1, <0.5"
@@ -58,9 +57,6 @@
version = "0.3"
optional = true
@ -18,3 +29,11 @@
[dev-dependencies.bencher]
version = "0.1"
@@ -75,7 +71,6 @@
[features]
heap_size = ["heapsize"]
-query_encoding = ["encoding"]
[badges.appveyor]
repository = "Manishearth/rust-url"

@ -1,29 +1,36 @@
# Generated by rust2rpm 15
## START: Set by rpmautospec
## (rpmautospec version 0.5.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 14;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
# * outdated dev-dependencies: serde_json ^0.6.1
%bcond_with check
%global debug_package %{nil}
%global crate url
Name: rust-%{crate}1
Name: rust-url1
Version: 1.7.2
Release: 8%{?dist}
Release: %autorelease
Summary: URL library for Rust, based on the WHATWG URL Standard
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/url
Source: %{crates_source}
# Initial patched metadata
# * Exclude CI files, https://github.com/servo/rust-url/pull/467
# * drop optional + unused serde feature (serde < 1 no longer available)
Patch0: url-fix-metadata.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional feature for supporting serde 0.9
# * drop unused optional feature for supporting encoding
# * exclude files that are only useful for upstream development
Patch: url-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
URL library for Rust, based on the WHATWG URL Standard.}
@ -36,13 +43,15 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md UPGRADING.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/UPGRADING.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,23 +59,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+encoding-devel %{_description}
This package contains library source intended for building other packages
which use "encoding" feature of "%{crate}" crate.
%files -n %{name}+encoding-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heap_size-devel
Summary: %{summary}
@ -74,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+heap_size-devel %{_description}
This package contains library source intended for building other packages
which use "heap_size" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "heap_size" feature of the "%{crate}" crate.
%files -n %{name}+heap_size-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heapsize-devel
Summary: %{summary}
@ -86,23 +83,11 @@ BuildArch: noarch
%description -n %{name}+heapsize-devel %{_description}
This package contains library source intended for building other packages
which use "heapsize" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "heapsize" feature of the "%{crate}" crate.
%files -n %{name}+heapsize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+query_encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+query_encoding-devel %{_description}
This package contains library source intended for building other packages
which use "query_encoding" feature of "%{crate}" crate.
%files -n %{name}+query_encoding-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc-serialize-devel
Summary: %{summary}
@ -110,14 +95,14 @@ BuildArch: noarch
%description -n %{name}+rustc-serialize-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-serialize" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustc-serialize" feature of the "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -135,9 +120,22 @@ which use "rustc-serialize" feature of "%{crate}" crate.
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.7.2-8
## START: Generated by rpmautospec
* Fri Jan 19 2024 Fabio Valentini <decathorpe@gmail.com> - 1.7.2-14
- Drop unused optional feature for supporting encoding
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.7.2-13
- Rebuilt for MSVSphere 9.3
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.7.2-12
- Regenerate with rust2rpm v24
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
@ -161,3 +159,5 @@ which use "rustc-serialize" feature of "%{crate}" crate.
* Sun Aug 25 08:47:13 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.7.2-1
- Initial package
## END: Generated by rpmautospec

Loading…
Cancel
Save