Drop unused optional feature for supporting encoding

epel9 imports/e9/rust-url1-1.7.2-14.el9
Fabio Valentini 1 year ago
parent 27cb3abd2f
commit 00768dcb2d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,4 +1,4 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
# * outdated dev-dependencies: serde_json ^0.6.1 # * outdated dev-dependencies: serde_json ^0.6.1
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -16,10 +16,11 @@ URL: https://crates.io/crates/url
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop unused optional feature for supporting serde 0.9 # * drop unused optional feature for supporting serde 0.9
# * drop unused optional feature for supporting encoding
# * exclude files that are only useful for upstream development # * exclude files that are only useful for upstream development
Patch: url-fix-metadata.diff Patch: url-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
URL library for Rust, based on the WHATWG URL Standard.} URL library for Rust, based on the WHATWG URL Standard.}
@ -54,18 +55,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+encoding-devel %{_description}
This package contains library source intended for building other packages which
use the "encoding" feature of the "%{crate}" crate.
%files -n %{name}+encoding-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heap_size-devel %package -n %{name}+heap_size-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -90,18 +79,6 @@ use the "heapsize" feature of the "%{crate}" crate.
%files -n %{name}+heapsize-devel %files -n %{name}+heapsize-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+query_encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+query_encoding-devel %{_description}
This package contains library source intended for building other packages which
use the "query_encoding" feature of the "%{crate}" crate.
%files -n %{name}+query_encoding-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc-serialize-devel %package -n %{name}+rustc-serialize-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -115,7 +92,7 @@ use the "rustc-serialize" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -0,0 +1,7 @@
[package]
summary = "URL library for Rust, based on the WHATWG URL Standard"
[tests]
run = ["none"]
comments = ["outdated dev-dependencies: serde_json ^0.6.1"]

@ -1,14 +1,25 @@
--- url-1.7.2/Cargo.toml 1970-01-01T00:00:00+00:00 --- url-1.7.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ url-1.7.2/Cargo.toml 2023-05-17T10:09:00.047183+00:00 +++ url-1.7.2/Cargo.toml 2024-01-19T19:11:15.829242+00:00
@@ -21,6 +21,7 @@ @@ -21,6 +21,8 @@
categories = ["parser-implementations", "web-programming", "encoding"] categories = ["parser-implementations", "web-programming", "encoding"]
license = "MIT/Apache-2.0" license = "MIT/Apache-2.0"
repository = "https://github.com/servo/rust-url" repository = "https://github.com/servo/rust-url"
+exclude = ["/docs/*", "/.travis.yml", "/appveyor.yml"] +exclude = ["/docs/*", "/.travis.yml", "/appveyor.yml"]
+
[package.metadata.docs.rs] [package.metadata.docs.rs]
features = ["query_encoding"] features = ["query_encoding"]
@@ -58,9 +59,6 @@ @@ -37,9 +39,6 @@
[[bench]]
name = "parse_url"
harness = false
-[dependencies.encoding]
-version = "0.2"
-optional = true
[dependencies.heapsize]
version = ">=0.4.1, <0.5"
@@ -58,9 +57,6 @@
version = "0.3" version = "0.3"
optional = true optional = true
@ -18,3 +29,11 @@
[dev-dependencies.bencher] [dev-dependencies.bencher]
version = "0.1" version = "0.1"
@@ -75,7 +71,6 @@
[features]
heap_size = ["heapsize"]
-query_encoding = ["encoding"]
[badges.appveyor]
repository = "Manishearth/rust-url"

Loading…
Cancel
Save