parent
b594937b4d
commit
e7a16b8960
@ -0,0 +1,30 @@
|
|||||||
|
From 9d500e76a0e1644c93b3869588f979e4440e74d6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Sapin <simon.sapin@exyr.org>
|
||||||
|
Date: Sun, 25 Feb 2018 08:21:55 +0100
|
||||||
|
Subject: [PATCH] Update to rustc_test 0.3, unbreak tests on nightly-2018-02-25
|
||||||
|
|
||||||
|
Version 0.2 of the crates.io package `rustc_test` uses `test` as its
|
||||||
|
rustc crate name, shadowing the `test` crate from the standard library.
|
||||||
|
This made up subject to breaking changes to its private APIs:
|
||||||
|
|
||||||
|
https://travis-ci.org/SimonSapin/run-nightly/builds/345808272#L549
|
||||||
|
---
|
||||||
|
tests/data.rs | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/data.rs b/tests/data.rs
|
||||||
|
index 8885f64..e9203b1 100644
|
||||||
|
--- a/tests/data.rs
|
||||||
|
+++ b/tests/data.rs
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
//! Data-driven tests
|
||||||
|
|
||||||
|
extern crate rustc_serialize;
|
||||||
|
-extern crate test;
|
||||||
|
+extern crate rustc_test as test;
|
||||||
|
extern crate url;
|
||||||
|
|
||||||
|
use rustc_serialize::json::{self, Json};
|
||||||
|
--
|
||||||
|
2.16.2
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- url-1.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ url-1.7.0/Cargo.toml 2018-03-13T12:28:19.050950+01:00
|
||||||
|
@@ -61,7 +61,7 @@
|
||||||
|
version = "0.3"
|
||||||
|
|
||||||
|
[dev-dependencies.rustc-test]
|
||||||
|
-version = "0.2"
|
||||||
|
+version = "0.3"
|
||||||
|
|
||||||
|
[dev-dependencies.serde_json]
|
||||||
|
version = ">=0.6.1, <0.9"
|
Loading…
Reference in new issue