Initial import (#2120005)
parent
3ab63d42c9
commit
43c7f9b434
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/unsafe-libyaml-0.2.2.crate
|
@ -0,0 +1,74 @@
|
||||
# Generated by rust2rpm 22
|
||||
# * tests can only be run in-tree
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate unsafe-libyaml
|
||||
|
||||
Name: rust-unsafe-libyaml
|
||||
Version: 0.2.2
|
||||
Release: %autorelease
|
||||
Summary: Libyaml transpiled to rust by c2rust
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/unsafe-libyaml
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * skip building unused test binaries
|
||||
Patch: unsafe-libyaml-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Libyaml transpiled to rust by c2rust.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (unsafe-libyaml-0.2.2.crate) = 385fed83536204170f356d3c430e7b898cfd6bd302396a63da119c55c874a5b54d0e54da0d018d7d9dab8361f268d8f645ed87f3406bbc2a07aef3a3f95712c2
|
@ -0,0 +1,10 @@
|
||||
--- unsafe-libyaml-0.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ unsafe-libyaml-0.2.2/Cargo.toml 2022-08-20T19:50:31.359289+00:00
|
||||
@@ -27,6 +27,7 @@
|
||||
license = "MIT"
|
||||
repository = "https://github.com/dtolnay/unsafe-libyaml"
|
||||
resolver = "2"
|
||||
+autobins = false
|
||||
|
||||
[package.metadata.docs.rs]
|
||||
targets = ["x86_64-unknown-linux-gnu"]
|
Loading…
Reference in new issue