Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 63d52121f3
commit 1e553f2010
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/unicode-xid-0.1.0.crate

@ -0,0 +1,103 @@
# Generated by rust2rpm 10
%bcond_with check
%global debug_package %{nil}
%global crate unicode-xid
Name: rust-%{crate}0.1
Version: 0.1.0
Release: 1%{?dist}
Summary: Determine whether characters have XID_Start/XID_Continue properties
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/unicode-xid
Source: %{crates_source}
# Initial patched metadata
# * Exclude scripts/*, https://github.com/unicode-rs/unicode-xid/pull/8
Patch0: unicode-xid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand:
Determine whether characters have the XID_Start or XID_Continue properties
according to Unicode Standard Annex #31.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE COPYRIGHT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+bench-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bench-devel %{_description}
This package contains library source intended for building other packages
which use "bench" feature of "%{crate}" crate.
%files -n %{name}+bench-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages
which use "no_std" feature of "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sun Aug 18 15:52:47 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.0-1
- Initial package

@ -0,0 +1 @@
SHA512 (unicode-xid-0.1.0.crate) = cc5343e2166938322cfd7c73f1f918f2a9c46846ac0ef55933d1e44cdfaf6f7da2b7ff18b68e356c47b6d8ba5565eda0db42c347dcbde830683f341ac2b1849d

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-unicode-xid0.1

@ -0,0 +1,11 @@
--- unicode-xid-0.1.0/Cargo.toml 2017-05-08T17:43:03+00:00
+++ unicode-xid-0.1.0/Cargo.toml 2019-08-18T13:52:47.543777+00:00
@@ -18,7 +18,7 @@
Unicode Standard Annex #31.
"""
-exclude = [ "target/*", "Cargo.lock" ]
+exclude = [ "target/*", "Cargo.lock", "/scripts/*" ]
[features]
default = []
Loading…
Cancel
Save