epel10
imports/epel10/rust-unicode-width0.1-0.1.14-1.el10
parent
aa6df6c1b9
commit
8dce1fdcca
@ -0,0 +1 @@
|
|||||||
|
/unicode-width-0.1.14.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-unicode-width0.1
|
|
||||||
|
|
||||||
The rust-unicode-width0.1 package
|
|
@ -0,0 +1,98 @@
|
|||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate unicode-width
|
||||||
|
|
||||||
|
Name: rust-unicode-width0.1
|
||||||
|
Version: 0.1.14
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Determine displayed width of 'char' and 'str' types
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/unicode-width
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * exclude scripts that are only useful for upstream development
|
||||||
|
Patch: unicode-width-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Determine displayed width of `char` and `str` types according to Unicode
|
||||||
|
Standard Annex #11 rules.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/COPYRIGHT
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+cjk-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+cjk-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "cjk" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+cjk-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+no_std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+no_std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "no_std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+no_std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,14 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Determine displayed width of 'char' and 'str' types"
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"exclude scripts that are only useful for upstream development",
|
||||||
|
]
|
||||||
|
|
||||||
|
[features]
|
||||||
|
hide = [
|
||||||
|
"compiler_builtins",
|
||||||
|
"core",
|
||||||
|
"std",
|
||||||
|
"rustc-dep-of-std",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (unicode-width-0.1.14.crate) = 3c58a18776aa82cc13c761789a47901616cd98a30356f93d7eb05ae457314209d0a66213e2bbfa5eb8b59be6beacf62438234ce8daafa31b128dbf7d5d6fcadb
|
@ -0,0 +1,11 @@
|
|||||||
|
--- unicode-width-0.1.14/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ unicode-width-0.1.14/Cargo.toml 2024-10-03T14:16:50.621877+00:00
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
"Manish Goregaokar <manishsmail@gmail.com>",
|
||||||
|
]
|
||||||
|
build = false
|
||||||
|
-exclude = ["/.github/*"]
|
||||||
|
+exclude = ["/scripts/*"]
|
||||||
|
autobins = false
|
||||||
|
autoexamples = false
|
||||||
|
autotests = false
|
Loading…
Reference in new issue