Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent e30ccceffc
commit e7e9c6c03d
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -7,23 +7,18 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.3.4 Version: 0.3.4
Release: 7%{?dist} Release: 8%{?dist}
Summary: Implementation of the Unicode Bidirectional Algorithm Summary: Implementation of the Unicode Bidirectional Algorithm
# Upstream license specification: MIT / Apache-2.0 # Upstream license specification: MIT / Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/unicode-bidi URL: https://crates.io/crates/unicode-bidi
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata
# * Flamer is nightly
Patch0: unicode-bidi-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(matches/default) >= 0.1.0 with crate(matches/default) < 0.2.0) BuildRequires: (crate(matches/default) >= 0.1.0 with crate(matches/default) < 0.2.0)
BuildRequires: (crate(serde/default) >= 0.8.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde/derive) >= 0.8.0 with crate(serde/derive) < 2.0.0)
%if %{with check} %if %{with check}
BuildRequires: (crate(serde_test/default) >= 0.8.0 with crate(serde_test/default) < 2.0.0) BuildRequires: (crate(serde_test/default) >= 0.8.0 with crate(serde_test/default) < 2.0.0)
%endif %endif
@ -96,7 +91,7 @@ which use "with_serde" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -112,6 +107,9 @@ which use "with_serde" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-8
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-7 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1,25 +0,0 @@
--- unicode-bidi-0.3.4/Cargo.toml 1970-01-01T01:00:00+01:00
+++ unicode-bidi-0.3.4/Cargo.toml 2018-11-03T14:41:00.278011+01:00
@@ -23,14 +23,6 @@
[lib]
name = "unicode_bidi"
-[dependencies.flame]
-version = "0.1"
-optional = true
-
-[dependencies.flamer]
-version = "0.1"
-optional = true
-
[dependencies.serde]
version = ">=0.8, <2.0"
features = ["derive"]
@@ -43,7 +35,6 @@
[features]
with_serde = ["serde"]
-flame_it = ["flame", "flamer"]
unstable = []
default = []
bench_it = []
Loading…
Cancel
Save