parent
6efbf9d58c
commit
dab9bb3b18
@ -0,0 +1 @@
|
|||||||
|
/unicode-bidi-0.3.4.crate
|
@ -0,0 +1,69 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate unicode-bidi
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.3.4
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Implementation of the Unicode Bidirectional Algorithm
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/unicode-bidi
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Flamer is nightly
|
||||||
|
Patch0: unicode-bidi-0.3.4-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(matches) >= 0.1.0 with crate(matches) < 0.2.0)
|
||||||
|
BuildRequires: ((crate(serde) >= 0.8.0 with crate(serde) < 2.0.0) with crate(serde/derive))
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(serde_test) >= 0.8.0 with crate(serde_test) < 2.0.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Implementation of the Unicode Bidirectional Algorithm.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# Full tests miss files, https://github.com/servo/unicode-bidi/issues/43
|
||||||
|
%cargo_test --doc
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license COPYRIGHT LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md AUTHORS
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-1
|
||||||
|
- Update to 0.3.4
|
||||||
|
|
||||||
|
* Wed Jul 05 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (unicode-bidi-0.3.4.crate) = 170ce083fa82bed13ecc62d85cb882fdd6491ae721e1633d3c1a5d3cee69422153afcf6695765c0e8fc7035440d0370d34afac9e978cb27f7506c07cba300e1e
|
@ -0,0 +1,24 @@
|
|||||||
|
--- unicode-bidi-0.3.4/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ unicode-bidi-0.3.4/Cargo.toml 2017-11-10T10:21:03.902269+01:00
|
||||||
|
@@ -23,13 +23,6 @@
|
||||||
|
|
||||||
|
[lib]
|
||||||
|
name = "unicode_bidi"
|
||||||
|
-[dependencies.flame]
|
||||||
|
-version = "0.1"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dependencies.flamer]
|
||||||
|
-version = "0.1"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[dependencies.serde]
|
||||||
|
version = ">=0.8, <2.0"
|
||||||
|
@@ -43,7 +36,6 @@
|
||||||
|
|
||||||
|
[features]
|
||||||
|
with_serde = ["serde"]
|
||||||
|
-flame_it = ["flame", "flamer"]
|
||||||
|
unstable = []
|
||||||
|
default = []
|
||||||
|
bench_it = []
|
Loading…
Reference in new issue