drop optional features with broken dependencies

epel9
Fabio Valentini 4 years ago
parent 39cb330646
commit 19bd07d0ba
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -7,13 +7,16 @@
Name: rust-%{crate}
Version: 0.12.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Library to build rich terminal user interfaces or dashboards
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/tui
Source: %{crates_source}
# Initial patched metadata
# * drop optional features with broken dependencies
Patch0: tui-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -65,54 +68,6 @@ which use "crossterm" feature of "%{crate}" crate.
%files -n %{name}+crossterm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+curses-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+curses-devel %{_description}
This package contains library source intended for building other packages
which use "curses" feature of "%{crate}" crate.
%files -n %{name}+curses-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+easycurses-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+easycurses-devel %{_description}
This package contains library source intended for building other packages
which use "easycurses" feature of "%{crate}" crate.
%files -n %{name}+easycurses-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+pancurses-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pancurses-devel %{_description}
This package contains library source intended for building other packages
which use "pancurses" feature of "%{crate}" crate.
%files -n %{name}+pancurses-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustbox-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustbox-devel %{_description}
This package contains library source intended for building other packages
which use "rustbox" feature of "%{crate}" crate.
%files -n %{name}+rustbox-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -156,6 +111,9 @@ which use "termion" feature of "%{crate}" crate.
%endif
%changelog
* Sun Nov 8 2020 Fabio Valentini <decathorpe@gmail.com> - 0.12.0-2
- Drop optional features with broken dependencies.
* Sun Oct 25 2020 Fabio Valentini <decathorpe@gmail.com> - 0.12.0-1
- Update to version 0.12.0.

@ -0,0 +1,30 @@
--- tui-0.12.0/Cargo.toml 2020-09-27T17:56:46+00:00
+++ tui-0.12.0/Cargo.toml 2020-11-08T21:45:13.996104+00:00
@@ -122,19 +122,6 @@
version = "0.17"
optional = true
-[dependencies.easycurses]
-version = "0.12.2"
-optional = true
-
-[dependencies.pancurses]
-version = "0.16.1"
-features = ["win32a"]
-optional = true
-
-[dependencies.rustbox]
-version = "0.11"
-optional = true
-
[dependencies.serde]
version = "1"
features = ["derive"]
@@ -156,7 +143,6 @@
version = "0.7"
[features]
-curses = ["easycurses", "pancurses"]
default = ["termion"]
[badges]
Loading…
Cancel
Save