Initial import (ttf-parser 0.12 compat package)

epel9
Fabio Valentini 3 years ago
parent 4eccf45a50
commit 9682b0b694
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

4
.gitignore vendored

@ -0,0 +1,4 @@
/results_*/
/*.src.rpm
/ttf-parser-0.12.3.crate

@ -1,3 +0,0 @@
# rust-ttf-parser0.12
The rust-ttf-parser0.12 package

@ -0,0 +1,108 @@
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate ttf-parser
Name: rust-%{crate}0.12
Version: 0.12.3
Release: %autorelease
Summary: High-level, safe, zero-allocation TrueType font parser
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/ttf-parser
Source: %{crates_source}
# Initial patched metadata
# * bump base64 dev-dependency from 0.12 to 0.13
# * bump svgtypes dev-dependency from 0.5 to 0.8
# * remove unused pico-args dev-dependency
Patch0: ttf-parser-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
High-level, safe, zero-allocation TrueType font parser.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%exclude %{crate_instdir}/meson.build
%exclude %{crate_instdir}/examples/wasm/
%exclude %{crate_instdir}/testing-tools/
%exclude %{crate_instdir}/tests/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+variable-fonts-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+variable-fonts-devel %{_description}
This package contains library source intended for building other packages which
use the "variable-fonts" feature of the "%{crate}" crate.
%files -n %{name}+variable-fonts-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# only unit tests are included in published crates
%cargo_test -- --lib
%cargo_test -- --doc
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (ttf-parser-0.12.3.crate) = c774409706b1767936929ce21e4fd7a31846aec8ee79a137de91bc46191958a7627e05a2ff09c02b421dbdb9052c9340ac66507e3d63b305e088de9183eef8a6

@ -0,0 +1,18 @@
--- ttf-parser-0.12.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ ttf-parser-0.12.3/Cargo.toml 2022-03-09T14:39:00.191217+00:00
@@ -24,13 +24,10 @@
license = "MIT OR Apache-2.0"
repository = "https://github.com/RazrFalcon/ttf-parser"
[dev-dependencies.base64]
-version = "0.12"
-
-[dev-dependencies.pico-args]
-version = "0.3.1"
+version = "0.13"
[dev-dependencies.svgtypes]
-version = "0.5"
+version = "0.8"
[dev-dependencies.xmlwriter]
version = "0.1"
Loading…
Cancel
Save