Initial import (#2246013)
parent
fddca1f5d4
commit
73a9ea8232
@ -0,0 +1 @@
|
||||
/trycmd-0.14.19.crate
|
@ -0,0 +1,168 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate trycmd
|
||||
|
||||
Name: rust-trycmd
|
||||
Version: 0.14.19
|
||||
Release: %autorelease
|
||||
Summary: Snapshot testing for a herd of CLI tests
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/trycmd
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * prevent unused binaries from being built and shipped
|
||||
Patch: trycmd-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Snapshot testing for a herd of CLI tests.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+color-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+color-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "color" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+color-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+color-auto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+color-auto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "color-auto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+color-auto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+diff-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+diff-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "diff" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+diff-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+escargot-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+escargot-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "escargot" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+escargot-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+examples-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+examples-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "examples" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+examples-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+filesystem-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+filesystem-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "filesystem" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+filesystem-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+schema-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+schema-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "schema" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+schema-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (trycmd-0.14.19.crate) = 6d6eae6bc1617a4ab5846716f6c1c800143c01e84f24df413bd7962e350f964976bf0583d399405dc6df638760e6fed3e418c1056239e9e39d00ea1355485672
|
@ -0,0 +1,24 @@
|
||||
--- trycmd-0.14.19/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ trycmd-0.14.19/Cargo.toml 2023-11-23T22:23:38.923500+00:00
|
||||
@@ -38,6 +38,7 @@
|
||||
categories = ["development-tools::testing"]
|
||||
license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/assert-rs/trycmd.git"
|
||||
+autobins = false
|
||||
|
||||
[package.metadata.docs.rs]
|
||||
all-features = true
|
||||
@@ -84,13 +85,6 @@
|
||||
<!-- next-url -->
|
||||
[Unreleased]: https://github.com/assert-rs/trycmd/compare/{{tag_name}}...HEAD"""
|
||||
search = "<!-- next-url -->"
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "bin-fixture"
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "trycmd-schema"
|
||||
-required-features = ["schema"]
|
||||
|
||||
[dependencies.anstream]
|
||||
version = "0.6.0"
|
Loading…
Reference in new issue