commit
eeca73f550
Binary file not shown.
@ -0,0 +1,26 @@
|
||||
--- trust-dns-resolver-0.23.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ trust-dns-resolver-0.23.2/Cargo.toml 2023-11-21T23:35:07.109856+00:00
|
||||
@@ -184,7 +184,6 @@
|
||||
"trust-dns-proto/serde-config",
|
||||
]
|
||||
system-config = [
|
||||
- "ipconfig",
|
||||
"resolv-conf",
|
||||
]
|
||||
testing = []
|
||||
@@ -193,10 +192,6 @@
|
||||
"trust-dns-proto/tokio-runtime",
|
||||
]
|
||||
|
||||
-[target."cfg(windows)".dependencies.ipconfig]
|
||||
-version = "0.3.0"
|
||||
-optional = true
|
||||
-
|
||||
[badges.codecov]
|
||||
branch = "main"
|
||||
repository = "bluejekyll/trust-dns"
|
||||
@@ -204,3 +199,4 @@
|
||||
|
||||
[badges.maintenance]
|
||||
status = "actively-developed"
|
||||
+
|
@ -0,0 +1,17 @@
|
||||
--- trust-dns-resolver-0.23.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ trust-dns-resolver-0.23.2/Cargo.toml 2023-11-21T23:35:17.275900+00:00
|
||||
@@ -128,14 +128,6 @@
|
||||
"test-util",
|
||||
]
|
||||
|
||||
-[dev-dependencies.tracing-subscriber]
|
||||
-version = "0.3"
|
||||
-features = [
|
||||
- "std",
|
||||
- "fmt",
|
||||
- "env-filter",
|
||||
-]
|
||||
-
|
||||
[features]
|
||||
default = [
|
||||
"system-config",
|
@ -0,0 +1,434 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
# * /etc/hosts and /etc/resolv.conf are not available in mock
|
||||
# * no internet connectivity in mock
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate trust-dns-resolver
|
||||
|
||||
Name: rust-trust-dns-resolver
|
||||
Version: 0.23.2
|
||||
Release: %autorelease
|
||||
Summary: Trust-DNS is a safe and secure DNS library
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/trust-dns-resolver
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: trust-dns-resolver-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * remove unused tracing-subscriber dev-dependency
|
||||
Patch: trust-dns-resolver-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Trust-DNS is a safe and secure DNS library. This Resolver library uses
|
||||
the Client library to perform all DNS queries. The Resolver is intended
|
||||
to be a high-level library for any DNS record resolution see Resolver
|
||||
and AsyncResolver for supported resolution types. The Client can be used
|
||||
for other queries.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-https-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-https-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-https" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-https-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-https-rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-https-rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-https-rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-https-rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-native-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-native-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-native-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-native-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-openssl-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-openssl-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-openssl" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-openssl-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-quic-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-quic-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-quic" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-quic-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-over-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-over-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns-over-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-over-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dnssec-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dnssec-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dnssec" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dnssec-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dnssec-openssl-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dnssec-openssl-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dnssec-openssl" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dnssec-openssl-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dnssec-ring-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dnssec-ring-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dnssec-ring" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dnssec-ring-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+resolv-conf-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+resolv-conf-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "resolv-conf" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+resolv-conf-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-config-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-config-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde-config" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-config-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+system-config-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+system-config-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "system-config" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+system-config-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+testing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+testing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "testing" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+testing-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-native-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-native-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-native-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-native-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-openssl-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-openssl-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-openssl" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-openssl-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-runtime-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-runtime-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-runtime" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-runtime-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+webpki-roots-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+webpki-roots-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "webpki-roots" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+webpki-roots-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.23.2-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Nov 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.23.2-1
|
||||
- Update to version 0.23.2; Fixes RHBZ#2245713
|
||||
|
||||
* Fri Oct 20 2023 Fabio Valentini <decathorpe@gmail.com> - 0.23.1-1
|
||||
- Update to version 0.23.1; Fixes RHBZ#2233604
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Feb 23 2023 Fabio Valentini <decathorpe@gmail.com> - 0.22.0-1
|
||||
- Update to version 0.22.0; Fixes RHBZ#2123798
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sun Jul 17 2022 Fabio Valentini <decathorpe@gmail.com> - 0.21.2-1
|
||||
- Update to version 0.21.2; Fixes RHBZ#2058876
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon Jun 07 2021 Fabio Valentini <decathorpe@gmail.com> - 0.20.3-1
|
||||
- Update to version 0.20.3.
|
||||
|
||||
* Sun Mar 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.20.1-1
|
||||
- Update to version 0.20.1.
|
||||
|
||||
* Mon Mar 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.20.0-1
|
||||
- Update to version 0.20.0.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.19.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Sun Dec 13 2020 Fabio Valentini <decathorpe@gmail.com> - 0.19.6-2
|
||||
- Remove features with missing dependencies (rustls, tokio-rustls, webpki-roots).
|
||||
|
||||
* Sun Nov 22 2020 Fabio Valentini <decathorpe@gmail.com> - 0.19.6-1
|
||||
- Update to version 0.19.6.
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.19.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue May 05 2020 Josh Stone <jistone@redhat.com> - 0.19.5-1
|
||||
- Update to 0.19.5
|
||||
|
||||
* Sun Apr 19 12:18:07 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.19.4-1
|
||||
- Update to 0.19.4
|
||||
|
||||
* Sun Feb 23 21:34:24 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.19.3-1
|
||||
- Update to 0.19.3
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Dec 25 17:56:38 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.18.0-1
|
||||
- Update to 0.18.0
|
||||
|
||||
* Sat Dec 14 13:58:38 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.18.0~alpha.2-1
|
||||
- Update to 0.18.0~alpha.2
|
||||
|
||||
* Fri Dec 13 01:16:39 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.12.0-1
|
||||
- Release 0.12.0
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Jun 22 23:10:02 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.1-2
|
||||
- Regenerate
|
||||
|
||||
* Fri May 31 08:48:00 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.1-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue