Update to version 0.23.1; Fixes RHBZ#2233604

epel9
Fabio Valentini 1 year ago
parent 77405937cc
commit ee9dc80e7a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/trust-dns-resolver-0.20.3.crate
/trust-dns-resolver-0.21.2.crate
/trust-dns-resolver-0.22.0.crate
/trust-dns-resolver-0.23.1.crate

@ -1,4 +1,4 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
# * /etc/hosts and /etc/resolv.conf are not available in mock
# * no internet connectivity in mock
%bcond_with check
@ -7,18 +7,20 @@
%global crate trust-dns-resolver
Name: rust-trust-dns-resolver
Version: 0.22.0
Version: 0.23.1
Release: %autorelease
Summary: Trust-DNS is a safe and secure DNS library
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/trust-dns-resolver
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: trust-dns-resolver-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove unused tracing-subscriber dev-dependency
Patch: trust-dns-resolver-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Trust-DNS is a safe and secure DNS library. This Resolver library uses
@ -237,7 +239,7 @@ use the "tokio-runtime" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -1,9 +0,0 @@
[DEFAULT]
unwanted-features =
rustls
tokio-rustls
webpki-roots
dns-over-https-rustls
dns-over-quic
dns-over-rustls
dnssec-ring

@ -0,0 +1,18 @@
[features]
hide = [
"rustls",
"tokio-rustls",
"webpki-roots",
"dns-over-https-rustls",
"dns-over-quic",
"dns-over-rustls",
"dnssec-ring",
]
[tests]
run = ["none"]
comments = [
"/etc/hosts and /etc/resolv.conf are not available in mock",
"no internet connectivity in mock",
]

@ -1 +1 @@
SHA512 (trust-dns-resolver-0.22.0.crate) = d1a9687a4e50925933e8f2f3624877c543ac91e8139422a198ca02e18161e24c19606c35dba1d546e8a0e4b0ad15c85d985fa45726b587b586932119d6bd68a1
SHA512 (trust-dns-resolver-0.23.1.crate) = 0023652f2f513b05490e7274ec493d488d2e51f826f5c8caab91ce82d0271ff937de499b83746f12a44f4d6c314d6dae883d4220abe5f1347caeb4958de89642

@ -1,6 +1,6 @@
--- trust-dns-resolver-0.22.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-resolver-0.22.0/Cargo.toml 2023-02-23T16:17:52.517930+00:00
@@ -172,7 +172,6 @@
--- trust-dns-resolver-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-resolver-0.23.1/Cargo.toml 2023-10-20T11:42:59.201738+00:00
@@ -184,7 +184,6 @@
"trust-dns-proto/serde-config",
]
system-config = [
@ -8,7 +8,7 @@
"resolv-conf",
]
testing = []
@@ -181,10 +180,6 @@
@@ -193,10 +192,6 @@
"trust-dns-proto/tokio-runtime",
]
@ -19,3 +19,8 @@
[badges.codecov]
branch = "main"
repository = "bluejekyll/trust-dns"
@@ -204,3 +199,4 @@
[badges.maintenance]
status = "actively-developed"
+

@ -1,16 +1,17 @@
--- trust-dns-resolver-0.21.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-resolver-0.21.2/Cargo.toml 2022-07-17T12:23:23.156278+00:00
@@ -115,12 +115,9 @@
dnssec-openssl = ["dnssec", "trust-dns-proto/dnssec-openssl"]
dnssec-ring = ["dnssec", "trust-dns-proto/dnssec-ring"]
serde-config = ["serde", "trust-dns-proto/serde-config"]
-system-config = ["ipconfig", "resolv-conf"]
+system-config = ["resolv-conf"]
testing = []
tokio-runtime = ["tokio/rt", "trust-dns-proto/tokio-runtime"]
-[target."cfg(windows)".dependencies.ipconfig]
-version = "0.3.0"
-optional = true
[badges.codecov]
branch = "main"
repository = "bluejekyll/trust-dns"
--- trust-dns-resolver-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-resolver-0.23.1/Cargo.toml 2023-10-20T11:43:06.042766+00:00
@@ -128,14 +128,6 @@
"test-util",
]
-[dev-dependencies.tracing-subscriber]
-version = "0.3"
-features = [
- "std",
- "fmt",
- "env-filter",
-]
-
[features]
default = [
"system-config",

Loading…
Cancel
Save