Update to version 0.23.2; Fixes RHBZ#2245715

epel9 imports/e9/rust-trust-dns-proto-0.23.2-1.el9
Fabio Valentini 1 year ago
parent 0521ee99b3
commit fac731dc41
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -12,3 +12,4 @@
/trust-dns-proto-0.21.2.crate
/trust-dns-proto-0.22.0.crate
/trust-dns-proto-0.23.1.crate
/trust-dns-proto-0.23.2.crate

@ -5,7 +5,7 @@
%global crate trust-dns-proto
Name: rust-trust-dns-proto
Version: 0.23.1
Version: 0.23.2
Release: %autorelease
Summary: Trust-DNS is a safe and secure DNS library
@ -13,9 +13,9 @@ License: MIT OR Apache-2.0
URL: https://crates.io/crates/trust-dns-proto
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump ring dependency from 0.16 to 0.17
# * remove unused tracing-subscriber dev-dependency
# * add missing "tokio/io-util" dependency for the "tokio-runtime" feature
# * move rustls-specific features from dns-over-https to dns-over-https-rustls
Patch: trust-dns-proto-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -89,6 +89,18 @@ use the "dns-over-https" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-https-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-https-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-https-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-https-rustls" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-https-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-native-tls-devel
Summary: %{summary}
BuildArch: noarch
@ -113,6 +125,30 @@ use the "dns-over-openssl" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-quic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-quic-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-quic" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-quic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-rustls" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-tls-devel
Summary: %{summary}
BuildArch: noarch
@ -149,6 +185,18 @@ use the "dnssec-openssl" feature of the "%{crate}" crate.
%files -n %{name}+dnssec-openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dnssec-ring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dnssec-ring-devel %{_description}
This package contains library source intended for building other packages which
use the "dnssec-ring" feature of the "%{crate}" crate.
%files -n %{name}+dnssec-ring-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+h2-devel
Summary: %{summary}
BuildArch: noarch
@ -209,6 +257,54 @@ use the "openssl" feature of the "%{crate}" crate.
%files -n %{name}+openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quinn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quinn-devel %{_description}
This package contains library source intended for building other packages which
use the "quinn" feature of the "%{crate}" crate.
%files -n %{name}+quinn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ring-devel %{_description}
This package contains library source intended for building other packages which
use the "ring" feature of the "%{crate}" crate.
%files -n %{name}+ring-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-pemfile-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-pemfile-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-pemfile" feature of the "%{crate}" crate.
%files -n %{name}+rustls-pemfile-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -317,6 +413,42 @@ use the "tokio-runtime" feature of the "%{crate}" crate.
%files -n %{name}+tokio-runtime-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-rustls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+webpki-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-devel %{_description}
This package contains library source intended for building other packages which
use the "webpki" feature of the "%{crate}" crate.
%files -n %{name}+webpki-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

@ -1,18 +1,7 @@
[features]
hide = [
"js-sys",
"quinn",
"ring",
"rustls",
"rustls-pemfile",
"tokio-rustls",
"wasm-bindgen-crate",
"webpki",
"webpki-roots",
"dns-over-https-rustls",
"dns-over-quic",
"dns-over-rustls",
"dnssec-ring",
"wasm-bindgen",
]

@ -1 +1 @@
SHA512 (trust-dns-proto-0.23.1.crate) = 4fcba616f02232e2172037e69bedf28f1a9e06f7639ec7640dc94404f7fc43eaf8829f8fe415a57cb71862e40907736a9c8c0ab89099386a46d8b1c236242acf
SHA512 (trust-dns-proto-0.23.2.crate) = 9f6d4ef2938f72f96ac02ddee1a5bf4a7ebc80f09aa16aad05484ab7b7e73bb9ef0d3729dac0180bf3aed380288a7422d3604c2655e03df22597b899e2fc85db

@ -1,38 +1,30 @@
--- trust-dns-proto-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-proto-0.23.1/Cargo.toml 2023-10-20T11:32:02.450133+00:00
@@ -221,14 +221,6 @@
"macros",
]
--- trust-dns-proto-0.23.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ trust-dns-proto-0.23.2/Cargo.toml 2023-11-22T00:08:40.241874+00:00
@@ -132,7 +132,7 @@
version = "0.8"
[dependencies.ring]
-version = "0.16"
+version = "0.17"
features = ["std"]
optional = true
@@ -219,14 +219,6 @@
"rt",
"time",
"macros",
-]
-
-[dev-dependencies.tracing-subscriber]
-version = "0.3"
-features = [
- "std",
- "fmt",
- "env-filter",
-]
-
]
[features]
backtrace = ["dep:backtrace"]
default = ["tokio-runtime"]
@@ -236,11 +228,13 @@
"bytes",
"h2",
"http",
+ "tokio-runtime",
+]
+dns-over-https-rustls = [
+ "dns-over-https",
"dns-over-rustls",
"webpki-roots",
- "tokio-runtime",
-]
-dns-over-https-rustls = ["dns-over-https"]
+]
dns-over-native-tls = [
"dns-over-tls",
"native-tls",
@@ -287,6 +281,7 @@
@@ -287,6 +279,7 @@
testing = []
text-parsing = []
tokio-runtime = [

Loading…
Cancel
Save