Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 4b13257f1f
commit 63456dbbee
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,12 +1,12 @@
# Generated by rust2rpm 9 # Generated by rust2rpm 10
%bcond_with check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate trust-dns-proto %global crate trust-dns-proto
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.7.4 Version: 0.7.4
Release: 1%{?dist} Release: 2%{?dist}
Summary: Trust-DNS is a safe and secure DNS library Summary: Trust-DNS is a safe and secure DNS library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -14,34 +14,13 @@ Summary: Trust-DNS is a safe and secure DNS library
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/trust-dns-proto URL: https://crates.io/crates/trust-dns-proto
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * No ring
Patch0: trust-dns-proto-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(byteorder/default) >= 1.2.0 with crate(byteorder/default) < 2.0.0)
BuildRequires: (crate(enum-as-inner/default) >= 0.2.0 with crate(enum-as-inner/default) < 0.3.0)
BuildRequires: (crate(failure/default) >= 0.1.0 with crate(failure/default) < 0.2.0)
BuildRequires: (crate(futures/default) >= 0.1.27 with crate(futures/default) < 0.2.0)
BuildRequires: (crate(idna/default) >= 0.1.4 with crate(idna/default) < 0.2.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.1 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
BuildRequires: (crate(smallvec/default) >= 0.6.0 with crate(smallvec/default) < 0.7.0)
BuildRequires: (crate(socket2/default) >= 0.3.9 with crate(socket2/default) < 0.4.0)
BuildRequires: (crate(tokio-executor/default) >= 0.1.7 with crate(tokio-executor/default) < 0.2.0)
BuildRequires: (crate(tokio-io/default) >= 0.1.0 with crate(tokio-io/default) < 0.2.0)
BuildRequires: (crate(tokio-reactor/default) >= 0.1.0 with crate(tokio-reactor/default) < 0.2.0)
BuildRequires: (crate(tokio-tcp/default) >= 0.1.0 with crate(tokio-tcp/default) < 0.2.0)
BuildRequires: (crate(tokio-timer/default) >= 0.2.10 with crate(tokio-timer/default) < 0.3.0)
BuildRequires: (crate(tokio-udp/default) >= 0.1.0 with crate(tokio-udp/default) < 0.2.0)
BuildRequires: (crate(url/default) >= 1.6.0 with crate(url/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(env_logger/default) >= 0.6.0 with crate(env_logger/default) < 0.7.0)
BuildRequires: (crate(tokio/default) >= 0.1.15 with crate(tokio/default) < 0.2.0)
%endif
%global _description %{expand: %global _description %{expand:
Trust-DNS is a safe and secure DNS library. This is the foundational DNS Trust-DNS is a safe and secure DNS library. This is the foundational DNS
@ -110,6 +89,18 @@ which use "dnssec-openssl" feature of "%{crate}" crate.
%files -n %{name}+dnssec-openssl-devel %files -n %{name}+dnssec-openssl-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+dnssec-ring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dnssec-ring-devel %{_description}
This package contains library source intended for building other packages
which use "dnssec-ring" feature of "%{crate}" crate.
%files -n %{name}+dnssec-ring-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+mdns-devel %package -n %{name}+mdns-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -134,6 +125,18 @@ which use "openssl" feature of "%{crate}" crate.
%files -n %{name}+openssl-devel %files -n %{name}+openssl-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+ring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ring-devel %{_description}
This package contains library source intended for building other packages
which use "ring" feature of "%{crate}" crate.
%files -n %{name}+ring-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -158,10 +161,25 @@ which use "serde-config" feature of "%{crate}" crate.
%files -n %{name}+serde-config-devel %files -n %{name}+serde-config-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+untrusted-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+untrusted-devel %{_description}
This package contains library source intended for building other packages
which use "untrusted" feature of "%{crate}" crate.
%files -n %{name}+untrusted-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -174,5 +192,8 @@ which use "serde-config" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sat Jun 22 23:15:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-2
- Regenerate
* Thu May 30 21:07:34 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-1 * Thu May 30 21:07:34 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-1
- Initial package - Initial package

@ -1,32 +0,0 @@
--- trust-dns-proto-0.7.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ trust-dns-proto-0.7.4/Cargo.toml 2019-05-30T19:07:34.586785+00:00
@@ -60,10 +60,6 @@
[dependencies.rand]
version = "0.6"
-[dependencies.ring]
-version = "0.14"
-optional = true
-
[dependencies.serde]
version = "1.0"
optional = true
@@ -92,10 +88,6 @@
[dependencies.tokio-udp]
version = "^0.1"
-[dependencies.untrusted]
-version = "^0.6"
-optional = true
-
[dependencies.url]
version = "1.6.0"
[dev-dependencies.env_logger]
@@ -107,7 +99,6 @@
[features]
dnssec = ["data-encoding"]
dnssec-openssl = ["dnssec", "openssl"]
-dnssec-ring = ["dnssec", "ring", "untrusted"]
mdns = ["socket2/reuseport"]
serde-config = ["serde"]
[badges.appveyor]
Loading…
Cancel
Save