commit
fe618f4d21
Binary file not shown.
@ -0,0 +1,22 @@
|
||||
--- trash-3.1.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ trash-3.1.2/Cargo.toml 2023-10-25T09:28:08.505965+00:00
|
||||
@@ -85,19 +85,3 @@
|
||||
[target."cfg(all(unix, not(target_os = \"macos\"), not(target_os = \"ios\"), not(target_os = \"android\")))".dependencies.url]
|
||||
version = "2.4.1"
|
||||
|
||||
-[target."cfg(any(target_os = \"dragonfly\", target_os = \"freebsd\", target_os = \"netbsd\", target_os = \"openbsd\"))".dependencies.once_cell]
|
||||
-version = "1.7.2"
|
||||
-
|
||||
-[target."cfg(target_os = \"macos\")".dependencies.objc]
|
||||
-version = "0.2.7"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.scopeguard]
|
||||
-version = "1.2.0"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.windows]
|
||||
-version = "0.44.0"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Com_StructuredStorage",
|
||||
- "Win32_UI_Shell_PropertiesSystem",
|
||||
-]
|
@ -0,0 +1,179 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
# * tests require an existing trash folder
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate trash
|
||||
|
||||
Name: rust-trash
|
||||
Version: 3.1.2
|
||||
Release: %autorelease
|
||||
Summary: Library for moving files and folders to the Recycle Bin
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/trash
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: trash-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A library for moving files and folders to the Recycle Bin.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE.txt
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+chrono-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+chrono-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "chrono" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+chrono-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+coinit_apartmentthreaded-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+coinit_apartmentthreaded-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "coinit_apartmentthreaded" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+coinit_apartmentthreaded-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+coinit_disable_ole1dde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+coinit_disable_ole1dde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "coinit_disable_ole1dde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+coinit_disable_ole1dde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+coinit_multithreaded-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+coinit_multithreaded-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "coinit_multithreaded" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+coinit_multithreaded-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+coinit_speed_over_memory-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+coinit_speed_over_memory-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "coinit_speed_over_memory" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+coinit_speed_over_memory-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.1.2-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Oct 25 2023 Fabio Valentini <decathorpe@gmail.com> - 3.1.2-1
|
||||
- Update to version 3.1.2; Fixes RHBZ#2242698
|
||||
|
||||
* Sat Jul 22 2023 Fabio Valentini <decathorpe@gmail.com> - 3.0.6-1
|
||||
- Update to version 3.0.6; Fixes RHBZ#2148703
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Wed Jul 13 2022 Fabio Valentini <decathorpe@gmail.com> - 2.1.5-1
|
||||
- Update to version 2.1.5; Fixes RHBZ#2090132
|
||||
|
||||
* Mon May 23 2022 Fabio Valentini <decathorpe@gmail.com> - 2.1.3-1
|
||||
- Update to version 2.1.3; Fixes RHBZ#2085314
|
||||
|
||||
* Wed May 11 2022 Fabio Valentini <decathorpe@gmail.com> - 2.1.1-1
|
||||
- Update to version 2.1.1; Fixes RHBZ#2082389
|
||||
|
||||
* Wed Jan 26 2022 Fabio Valentini <decathorpe@gmail.com> - 2.0.4-1
|
||||
- Update to version 2.0.4; Fixes RHBZ#2043976
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jan 07 2022 Fabio Valentini <decathorpe@gmail.com> - 2.0.3-1
|
||||
- Update to version 2.0.3; Fixes RHBZ#2035130
|
||||
|
||||
* Sun Nov 28 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 2.0.2-1
|
||||
- Initial import
|
Loading…
Reference in new issue