parent
67fbe2af29
commit
91368490a4
@ -0,0 +1 @@
|
|||||||
|
/trash-2.0.2.crate
|
@ -0,0 +1,125 @@
|
|||||||
|
# Generated by rust2rpm 19
|
||||||
|
# * Not really good idea to run tests as it messes with trash folder ☺
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate trash
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 2.0.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Library for moving files and folders to the Recycle Bin
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/trash
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
Patch0: trash-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Library for moving files and folders to the Recycle Bin.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE.txt
|
||||||
|
%doc CHANGELOG.md README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "the default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+coinit_apartmentthreaded-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+coinit_apartmentthreaded-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "the coinit_apartmentthreaded" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+coinit_apartmentthreaded-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+coinit_disable_ole1dde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+coinit_disable_ole1dde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "the coinit_disable_ole1dde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+coinit_disable_ole1dde-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+coinit_multithreaded-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+coinit_multithreaded-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "the coinit_multithreaded" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+coinit_multithreaded-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+coinit_speed_over_memory-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+coinit_speed_over_memory-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use "the coinit_speed_over_memory" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+coinit_speed_over_memory-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (trash-2.0.2.crate) = 88d512a7caa8b9163908bc2dc9240134b642d1b7a94ad15715ce391f250c8b14d2df4010c7c3213af219b433185e20bfdfef2545ae030053901faa6a1926f1bc
|
@ -0,0 +1,22 @@
|
|||||||
|
--- trash-2.0.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ trash-2.0.2/Cargo.toml 2021-11-28T13:11:04.103266+00:00
|
||||||
|
@@ -33,8 +33,6 @@
|
||||||
|
|
||||||
|
[dev-dependencies.rand]
|
||||||
|
version = "0.8.3"
|
||||||
|
-[build-dependencies.windows]
|
||||||
|
-version = "0.9.0"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
coinit_apartmentthreaded = []
|
||||||
|
@@ -53,10 +51,3 @@
|
||||||
|
|
||||||
|
[target."cfg(target_os = \"linux\")".dependencies.url]
|
||||||
|
version = "2.1.0"
|
||||||
|
-[target."cfg(target_os = \"macos\")".dependencies.objc]
|
||||||
|
-version = "0.2.7"
|
||||||
|
-[target."cfg(windows)".dependencies.scopeguard]
|
||||||
|
-version = "1.0.0"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dependencies.windows]
|
||||||
|
-version = "0.9.0"
|
Loading…
Reference in new issue