parent
91e46219db
commit
aebc0c3ea5
@ -0,0 +1 @@
|
|||||||
|
/transpose-0.2.2.crate
|
@ -0,0 +1,72 @@
|
|||||||
|
# Generated by rust2rpm 23
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate transpose
|
||||||
|
|
||||||
|
Name: rust-transpose
|
||||||
|
Version: 0.2.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Utility for transposing multi-dimensional data
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/transpose
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
Patch: transpose-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Utility for transposing multi-dimensional data.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/RELEASES.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (transpose-0.2.2.crate) = a08347773fba17586fd42f8e6ccd17c30f6d6c22faf391c6ff57ece99147754366b4273b41186a206f54b2be0bd3b29b2ef49182d23f0cfd11137cb49368338f
|
@ -0,0 +1,9 @@
|
|||||||
|
--- transpose-0.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ transpose-0.2.2/Cargo.toml 2022-11-09T02:27:26.136100+00:00
|
||||||
|
@@ -39,6 +39,3 @@
|
||||||
|
|
||||||
|
[dependencies.strength_reduce]
|
||||||
|
version = "^0.2.1"
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3"
|
Loading…
Reference in new issue