commit
a4eab5a6e9
Binary file not shown.
@ -0,0 +1,12 @@
|
||||
--- tracing-0.1.40/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tracing-0.1.40/Cargo.toml 2023-11-10T21:18:56.987190+00:00
|
||||
@@ -136,8 +136,6 @@
|
||||
std = ["tracing-core/std"]
|
||||
valuable = ["tracing-core/valuable"]
|
||||
|
||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
|
||||
-version = "^0.3"
|
||||
-
|
||||
[badges.maintenance]
|
||||
status = "actively-developed"
|
||||
+
|
@ -0,0 +1,64 @@
|
||||
--- tracing-0.1.40/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tracing-0.1.40/Cargo.toml 2023-11-10T21:19:29.856341+00:00
|
||||
@@ -51,42 +51,6 @@
|
||||
"tracing_unstable",
|
||||
]
|
||||
|
||||
-[[bench]]
|
||||
-name = "baseline"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "dispatch_get_clone"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "dispatch_get_ref"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "empty_span"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "enter_span"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "event"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "span_fields"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "span_no_fields"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "span_repeated"
|
||||
-harness = false
|
||||
-
|
||||
[dependencies.log]
|
||||
version = "0.4.17"
|
||||
optional = true
|
||||
@@ -101,10 +65,6 @@
|
||||
[dependencies.tracing-core]
|
||||
version = "0.1.32"
|
||||
default-features = false
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3.6"
|
||||
-default_features = false
|
||||
|
||||
[dev-dependencies.futures]
|
||||
version = "0.3.21"
|
||||
@@ -134,7 +94,6 @@
|
||||
release_max_level_trace = []
|
||||
release_max_level_warn = []
|
||||
std = ["tracing-core/std"]
|
||||
-valuable = ["tracing-core/valuable"]
|
||||
|
||||
[badges.maintenance]
|
||||
status = "actively-developed"
|
@ -0,0 +1,382 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tracing
|
||||
|
||||
Name: rust-tracing
|
||||
Version: 0.1.40
|
||||
Release: %autorelease
|
||||
Summary: Application-level tracing for Rust
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/tracing
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: tracing-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
# * drop unstable "valuable" feature
|
||||
Patch: tracing-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Application-level tracing for Rust.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-await-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-await-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async-await" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-await-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+attributes-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+attributes-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "attributes" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+attributes-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+log-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+log-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "log" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+log-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+log-always-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+log-always-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "log-always" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+log-always-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_error-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_error-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_error" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_error-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_info-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_info-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_info" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_info-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_off-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_off-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_off" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_off-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_trace-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_trace-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_trace" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_trace-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+max_level_warn-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+max_level_warn-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "max_level_warn" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+max_level_warn-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_error-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_error-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_error" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_error-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_info-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_info-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_info" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_info-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_off-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_off-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_off" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_off-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_trace-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_trace-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_trace" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_trace-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+release_max_level_warn-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+release_max_level_warn-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "release_max_level_warn" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+release_max_level_warn-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tracing-attributes-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tracing-attributes-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tracing-attributes" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tracing-attributes-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * integration tests can only be run in-tree
|
||||
%cargo_test -- --lib
|
||||
%cargo_test -- --doc
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jan 11 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.1.40-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Fri Nov 10 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.40-1
|
||||
- Update to version 0.1.40; Fixes RHBZ#2244964
|
||||
|
||||
* Sun Oct 15 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.39-1
|
||||
- Update to version 0.1.39; Fixes RHBZ#2244136
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.38-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon May 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.38-1
|
||||
- Update to version 0.1.38; Fixes RHBZ#2189637
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.37-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Oct 08 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.37-1
|
||||
- Update to version 0.1.37; Fixes RHBZ#2132826
|
||||
|
||||
* Wed Aug 10 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.36-1
|
||||
- Update to version 0.1.36; Fixes RHBZ#2112498
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.35-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.35-1
|
||||
- Update to version 0.1.35; Fixes RHBZ#2094933
|
||||
|
||||
* Tue May 24 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.34-1
|
||||
- Update to version 0.1.34; Fixes RHBZ#2073710
|
||||
|
||||
* Thu Mar 31 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.32-1
|
||||
- Update to version 0.1.32; Fixes RHBZ#2062408
|
||||
|
||||
* Fri Feb 18 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.31-1
|
||||
- Update to version 0.1.31; Fixes RHBZ#2055914
|
||||
|
||||
* Sat Feb 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.30-1
|
||||
- Update to version 0.1.30; Fixes RHBZ#2050454
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Nov 09 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.29-1
|
||||
- Update to version 0.1.29; Fixes RHBZ#2011111
|
||||
|
||||
* Fri Oct 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.28-1
|
||||
- Update to version 0.1.28; Fixes RHBZ#2003825
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.26-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed May 05 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.26-1
|
||||
- Update to version 0.1.26.
|
||||
|
||||
* Sat Feb 27 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.25-1
|
||||
- Update to version 0.1.25.
|
||||
|
||||
* Sun Feb 07 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.23-1
|
||||
- Update to version 0.1.23.
|
||||
- Fixes RHBZ#1925331
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.22-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Nov 27 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.22-1
|
||||
- Update to version 0.1.22.
|
||||
- Fixes RHBZ#1900911
|
||||
|
||||
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.21-1
|
||||
- Update to version 0.1.21.
|
||||
|
||||
* Tue Aug 25 2020 Josh Stone <jistone@redhat.com> - 0.1.19-1
|
||||
- Update to 0.1.19
|
||||
|
||||
* Thu Jul 23 2020 Josh Stone <jistone@redhat.com> - 0.1.17-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue