import rust-tracing-subscriber-0.3.18-1.el9

i9ce changed/i9ce/rust-tracing-subscriber-0.3.18-1.el9
Arkady L. Shane 1 year ago
commit 4d879f2d8e
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,25 @@
--- tracing-subscriber-0.3.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.18/Cargo.toml 2023-11-14T23:44:03.903973+00:00
@@ -226,21 +226,9 @@
]
valuable = [
"tracing-core/valuable",
- "valuable_crate",
- "valuable-serde",
"tracing-serde/valuable",
]
-
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
-version = "0.1.0"
-optional = true
-default-features = false
-
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
-version = "0.1.0"
-optional = true
-default-features = false
-package = "valuable"
[badges.maintenance]
status = "experimental"
+

@ -0,0 +1,13 @@
--- tracing-subscriber-0.3.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.18/Cargo.toml 2023-11-14T23:44:11.791999+00:00
@@ -224,10 +224,6 @@
"alloc",
"tracing-core/std",
]
-valuable = [
- "tracing-core/valuable",
- "tracing-serde/valuable",
-]
[badges.maintenance]
status = "experimental"

@ -0,0 +1,371 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}
%global crate tracing-subscriber
Name: rust-tracing-subscriber
Version: 0.3.18
Release: %autorelease
Summary: Utilities for implementing and composing tracing subscribers
License: MIT
URL: https://crates.io/crates/tracing-subscriber
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: tracing-subscriber-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unstable-only valuable feature
Patch: tracing-subscriber-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Utilities for implementing and composing `tracing` subscribers.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansi-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansi-devel %{_description}
This package contains library source intended for building other packages which
use the "ansi" feature of the "%{crate}" crate.
%files -n %{name}+ansi-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+env-filter-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+env-filter-devel %{_description}
This package contains library source intended for building other packages which
use the "env-filter" feature of the "%{crate}" crate.
%files -n %{name}+env-filter-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fmt-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fmt-devel %{_description}
This package contains library source intended for building other packages which
use the "fmt" feature of the "%{crate}" crate.
%files -n %{name}+fmt-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+json-devel %{_description}
This package contains library source intended for building other packages which
use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+local-time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+local-time-devel %{_description}
This package contains library source intended for building other packages which
use the "local-time" feature of the "%{crate}" crate.
%files -n %{name}+local-time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+matchers-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+matchers-devel %{_description}
This package contains library source intended for building other packages which
use the "matchers" feature of the "%{crate}" crate.
%files -n %{name}+matchers-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nu-ansi-term-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nu-ansi-term-devel %{_description}
This package contains library source intended for building other packages which
use the "nu-ansi-term" feature of the "%{crate}" crate.
%files -n %{name}+nu-ansi-term-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking_lot-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking_lot-devel %{_description}
This package contains library source intended for building other packages which
use the "parking_lot" feature of the "%{crate}" crate.
%files -n %{name}+parking_lot-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+registry-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+registry-devel %{_description}
This package contains library source intended for building other packages which
use the "registry" feature of the "%{crate}" crate.
%files -n %{name}+registry-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sharded-slab-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sharded-slab-devel %{_description}
This package contains library source intended for building other packages which
use the "sharded-slab" feature of the "%{crate}" crate.
%files -n %{name}+sharded-slab-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+thread_local-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thread_local-devel %{_description}
This package contains library source intended for building other packages which
use the "thread_local" feature of the "%{crate}" crate.
%files -n %{name}+thread_local-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tracing-devel %{_description}
This package contains library source intended for building other packages which
use the "tracing" feature of the "%{crate}" crate.
%files -n %{name}+tracing-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tracing-log-devel %{_description}
This package contains library source intended for building other packages which
use the "tracing-log" feature of the "%{crate}" crate.
%files -n %{name}+tracing-log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tracing-serde-devel %{_description}
This package contains library source intended for building other packages which
use the "tracing-serde" feature of the "%{crate}" crate.
%files -n %{name}+tracing-serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.18-1
- Rebuilt for MSVSphere 9.3
* Sun Dec 31 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.18-1
- Update to version 0.3.18; Fixes RHBZ#2249543
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.17-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon May 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.17-1
- Initial import (#2187797)
Loading…
Cancel
Save