Initial import (#2187797)
parent
6e610d81fb
commit
2c1dd16201
@ -0,0 +1 @@
|
|||||||
|
/tracing-subscriber-0.3.17.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-tracing-subscriber
|
|
||||||
|
|
||||||
The rust-tracing-subscriber package
|
|
@ -0,0 +1,340 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
# * tests can only be run in-tree
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate tracing-subscriber
|
||||||
|
|
||||||
|
Name: rust-tracing-subscriber
|
||||||
|
Version: 0.3.17
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Utilities for implementing and composing tracing subscribers
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/tracing-subscriber
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: tracing-subscriber-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||||
|
# * drop unstable valuable feature
|
||||||
|
Patch: tracing-subscriber-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Utilities for implementing and composing `tracing` subscribers.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+ansi-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+ansi-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "ansi" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+ansi-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+env-filter-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+env-filter-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "env-filter" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+env-filter-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+fmt-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+fmt-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "fmt" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+fmt-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+json-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+json-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "json" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+json-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+local-time-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+local-time-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "local-time" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+local-time-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+matchers-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+matchers-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "matchers" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+matchers-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+nu-ansi-term-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+nu-ansi-term-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "nu-ansi-term" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+nu-ansi-term-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+once_cell-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+once_cell-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "once_cell" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+once_cell-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+parking_lot-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+parking_lot-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "parking_lot" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+parking_lot-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+registry-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+registry-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "registry" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+registry-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde_json-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde_json-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde_json" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde_json-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+sharded-slab-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+sharded-slab-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "sharded-slab" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+sharded-slab-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+smallvec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+smallvec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "smallvec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+smallvec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+thread_local-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+thread_local-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "thread_local" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+thread_local-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+time-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+time-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "time" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+time-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tracing-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tracing-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tracing" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tracing-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tracing-log-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tracing-log-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tracing-log" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tracing-log-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tracing-serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tracing-serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tracing-serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tracing-serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (tracing-subscriber-0.3.17.crate) = 53a2a760d833f729e042b4f76b56c93ff7c50ddba968dfa9294f24425fe9a3dfc6c3b95a526ebd78df852b48b76c85d2f4f7be9170d75a6eea8734f77218e727
|
@ -0,0 +1,24 @@
|
|||||||
|
--- tracing-subscriber-0.3.17/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ tracing-subscriber-0.3.17/Cargo.toml 2023-05-29T21:10:41.743187+00:00
|
||||||
|
@@ -216,21 +216,8 @@
|
||||||
|
]
|
||||||
|
valuable = [
|
||||||
|
"tracing-core/valuable",
|
||||||
|
- "valuable_crate",
|
||||||
|
- "valuable-serde",
|
||||||
|
"tracing-serde/valuable",
|
||||||
|
]
|
||||||
|
-
|
||||||
|
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
|
||||||
|
-version = "0.1.0"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
|
||||||
|
-version = "0.1.0"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-package = "valuable"
|
||||||
|
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "experimental"
|
@ -0,0 +1,24 @@
|
|||||||
|
--- tracing-subscriber-0.3.17/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ tracing-subscriber-0.3.17/Cargo.toml 2023-05-29T21:11:30.797488+00:00
|
||||||
|
@@ -134,10 +134,6 @@
|
||||||
|
version = "0.1.3"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3.6"
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[dev-dependencies.log]
|
||||||
|
version = "0.4.17"
|
||||||
|
|
||||||
|
@@ -214,10 +210,6 @@
|
||||||
|
"alloc",
|
||||||
|
"tracing-core/std",
|
||||||
|
]
|
||||||
|
-valuable = [
|
||||||
|
- "tracing-core/valuable",
|
||||||
|
- "tracing-serde/valuable",
|
||||||
|
-]
|
||||||
|
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "experimental"
|
Loading…
Reference in new issue