commit
53a938cf56
Binary file not shown.
@ -0,0 +1,20 @@
|
|||||||
|
--- tracing-serde-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ tracing-serde-0.1.3/Cargo.toml 2023-03-01T21:27:58.938813+00:00
|
||||||
|
@@ -30,16 +30,6 @@
|
||||||
|
version = "1"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-valuable = ["valuable_crate", "valuable-serde", "tracing-core/valuable"]
|
||||||
|
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
|
||||||
|
-version = "0.1.0"
|
||||||
|
-optional = true
|
||||||
|
-default_features = false
|
||||||
|
-
|
||||||
|
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
|
||||||
|
-version = "0.1.0"
|
||||||
|
-optional = true
|
||||||
|
-default_features = false
|
||||||
|
-package = "valuable"
|
||||||
|
+valuable = ["tracing-core/valuable"]
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "experimental"
|
@ -0,0 +1,10 @@
|
|||||||
|
--- tracing-serde-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ tracing-serde-0.1.3/Cargo.toml 2023-03-01T21:28:07.386841+00:00
|
||||||
|
@@ -29,7 +29,5 @@
|
||||||
|
[dev-dependencies.serde_json]
|
||||||
|
version = "1"
|
||||||
|
|
||||||
|
-[features]
|
||||||
|
-valuable = ["tracing-core/valuable"]
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "experimental"
|
@ -0,0 +1,88 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate tracing-serde
|
||||||
|
|
||||||
|
Name: rust-tracing-serde
|
||||||
|
Version: 0.1.3
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Compatibility layer for serializing trace data with serde
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/tracing-serde
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: tracing-serde-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unstable valuable feature
|
||||||
|
Patch: tracing-serde-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A compatibility layer for serializing trace data with `serde`.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.1.3-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Fri Apr 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.3-1
|
||||||
|
- Initial import (#2187791)
|
Loading…
Reference in new issue