Update to version 0.1.33; Fixes RHBZ#2328815

epel10 imports/epel10/rust-tracing-core-0.1.33-1.el10
Fabio Valentini 3 months ago
parent b961ec5b01
commit 54b62f69c2
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -13,3 +13,4 @@
/tracing-core-0.1.30.crate
/tracing-core-0.1.31.crate
/tracing-core-0.1.32.crate
/tracing-core-0.1.33.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate tracing-core
Name: rust-tracing-core
Version: 0.1.32
Version: 0.1.33
Release: %autorelease
Summary: Core primitives for application-level tracing
@ -90,7 +90,7 @@ use the "std" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip a test that fails since Rust 1.52.1 but is not reproducible upstream
%cargo_test -- -- --skip field::test::value_sets_with_fields_from_other_callsites_are_empty
%cargo_test -- -- --exact --skip field::test::value_sets_with_fields_from_other_callsites_are_empty
%endif
%changelog

@ -1,3 +1,5 @@
[tests]
skip = ["field::test::value_sets_with_fields_from_other_callsites_are_empty"]
skip-exact = true
comments = ["skip a test that fails since Rust 1.52.1 but is not reproducible upstream"]

@ -1 +1 @@
SHA512 (tracing-core-0.1.32.crate) = 164f79cacfcca533a53b7dbbdc2015aaf851a16e00c72fbc4e5f515b6a6dedfa464e964810009b54f08cbcdc5a314e50245ac7b1b01a71fce4c63db135bf5521
SHA512 (tracing-core-0.1.33.crate) = 1c6f0cf3b7bd6c8f6316ed9ea0b315a619308de6cbf7e50e665a193cf8c3399b5227d4f145d83b10c7e01a2f9fbc83d16e108cf09b7fd6cef413aa5c1acf89ef

@ -1,18 +1,22 @@
--- tracing-core-0.1.32/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-core-0.1.32/Cargo.toml 2023-10-15T10:23:18.475851+00:00
@@ -53,14 +53,9 @@
--- tracing-core-0.1.33/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-core-0.1.33/Cargo.toml 2024-11-26T14:35:36.960475+00:00
@@ -83,14 +83,8 @@
[features]
default = [
"std",
- "valuable/std",
- "valuable?/std",
]
std = ["once_cell"]
-
-[target."cfg(tracing_unstable)".dependencies.valuable]
-version = "0.1.0"
-optional = true
-default-features = false
-
[badges.maintenance]
status = "actively-developed"
@@ -102,3 +96,4 @@
"cfg(flaky_tests)",
"cfg(tracing_unstable)",
]
+

Loading…
Cancel
Save