commit
eb2bc278fe
Binary file not shown.
@ -0,0 +1,38 @@
|
||||
--- tokio-0.2.25/Cargo.toml 2021-01-28T14:36:45+00:00
|
||||
+++ tokio-0.2.25/Cargo.toml 2023-05-22T19:17:34.570877+00:00
|
||||
@@ -107,11 +107,11 @@
|
||||
io-util = ["memchr"]
|
||||
macros = ["tokio-macros"]
|
||||
net = ["dns", "tcp", "udp", "uds"]
|
||||
-process = ["io-driver", "libc", "mio-named-pipes", "signal", "winapi/consoleapi", "winapi/minwindef", "winapi/threadpoollegacyapiset", "winapi/winerror"]
|
||||
+process = ["io-driver", "libc", "signal"]
|
||||
rt-core = ["slab"]
|
||||
rt-threaded = ["num_cpus", "rt-core"]
|
||||
rt-util = []
|
||||
-signal = ["io-driver", "lazy_static", "libc", "mio-uds", "signal-hook-registry", "winapi/consoleapi", "winapi/minwindef"]
|
||||
+signal = ["io-driver", "lazy_static", "libc", "mio-uds", "signal-hook-registry"]
|
||||
stream = ["futures-core"]
|
||||
sync = ["fnv"]
|
||||
tcp = ["io-driver", "iovec"]
|
||||
@@ -119,9 +119,6 @@
|
||||
time = ["slab"]
|
||||
udp = ["io-driver"]
|
||||
uds = ["io-driver", "mio-uds", "libc"]
|
||||
-[target."cfg(loom)".dev-dependencies.loom]
|
||||
-version = "0.3.5"
|
||||
-features = ["futures", "checkpoint"]
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.42"
|
||||
optional = true
|
||||
@@ -133,11 +130,3 @@
|
||||
[target."cfg(unix)".dependencies.signal-hook-registry]
|
||||
version = "1.1.1"
|
||||
optional = true
|
||||
-[target."cfg(windows)".dependencies.mio-named-pipes]
|
||||
-version = "0.1.6"
|
||||
-optional = true
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.8"
|
||||
-optional = true
|
||||
-default-features = false
|
@ -0,0 +1,526 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
# * outdated dev-dependencies: proptest 0.9, tokio-test 0.2
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tokio
|
||||
|
||||
Name: rust-tokio0.2
|
||||
Version: 0.2.25
|
||||
Release: %autorelease
|
||||
Summary: Event-driven, non-blocking I/O platform
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/tokio
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: tokio-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
An event-driven, non-blocking I/O platform for writing asynchronous I/O
|
||||
backed applications.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+blocking-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+blocking-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "blocking" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+blocking-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dns-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dns-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dns" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dns-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+fnv-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+fnv-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "fnv" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+fnv-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+fs-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+fs-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "fs" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+fs-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+full-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+full-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "full" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+full-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io-driver-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io-driver-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io-driver" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io-driver-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io-std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io-std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io-std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io-std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+iovec-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+iovec-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "iovec" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+iovec-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+lazy_static-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+lazy_static-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "lazy_static" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+lazy_static-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "libc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+macros-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+macros-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "macros" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+macros-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+memchr-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+memchr-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "memchr" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+memchr-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+mio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+mio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "mio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+mio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+mio-uds-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+mio-uds-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "mio-uds" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+mio-uds-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+net-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+net-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "net" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+net-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+num_cpus-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+num_cpus-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "num_cpus" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+num_cpus-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+parking_lot-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+parking_lot-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "parking_lot" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+parking_lot-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+process-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+process-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "process" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+process-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rt-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rt-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rt-core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rt-core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rt-threaded-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rt-threaded-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rt-threaded" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rt-threaded-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rt-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rt-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rt-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rt-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+signal-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+signal-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "signal" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+signal-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+signal-hook-registry-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+signal-hook-registry-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "signal-hook-registry" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+signal-hook-registry-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+slab-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+slab-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "slab" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+slab-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+stream-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+stream-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "stream" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+stream-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+sync-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+sync-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "sync" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+sync-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tcp-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tcp-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tcp" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tcp-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+test-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+test-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "test-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+test-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+time-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+time-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "time" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+time-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-macros-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-macros-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-macros" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-macros-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tracing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tracing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tracing" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tracing-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+udp-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+udp-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "udp" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+udp-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+uds-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+uds-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "uds" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+uds-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.25-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Mon May 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.25-1
|
||||
- Update to version 0.2.25
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.24-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.24-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.24-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.24-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.24-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Jan 11 20:04:14 CET 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.2.24-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue