Update to version 0.2.25

epel9 imports/e9/rust-tokio0.2-0.2.25-1.el9
Fabio Valentini 2 years ago
parent 2a0498418a
commit 1f88e472e4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/tokio-0.2.24.crate
/tokio-0.2.25.crate

@ -1,3 +0,0 @@
# rust-tokio0.2
The rust-tokio0.2 package

@ -1,32 +1,26 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 24
# * outdated dev-dependencies: proptest 0.9, tokio-test 0.2
%bcond_with check
%global debug_package %{nil}
%global crate tokio
Name: rust-%{crate}0.2
Version: 0.2.24
Name: rust-tokio0.2
Version: 0.2.25
Release: %autorelease
Summary: Event-driven, non-blocking I/O platform for writing asynchronous I/O backed applications
Summary: Event-driven, non-blocking I/O platform
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/tokio
Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: tokio-fix-metadata.diff
# Automatically generated patch to strip foreign dependencies
Patch: tokio-fix-metadata-auto.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Event-driven, non-blocking I/O platform for writing asynchronous I/O backed
applications.}
An event-driven, non-blocking I/O platform for writing asynchronous I/O
backed applications.}
%description %{_description}
@ -36,13 +30,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blocking-devel
Summary: %{summary}
@ -62,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+blocking-devel %{_description}
This package contains library source intended for building other packages
which use "blocking" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "blocking" feature of the "%{crate}" crate.
%files -n %{name}+blocking-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-devel
Summary: %{summary}
@ -74,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+dns-devel %{_description}
This package contains library source intended for building other packages
which use "dns" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "dns" feature of the "%{crate}" crate.
%files -n %{name}+dns-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fnv-devel
Summary: %{summary}
@ -86,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+fnv-devel %{_description}
This package contains library source intended for building other packages
which use "fnv" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "fnv" feature of the "%{crate}" crate.
%files -n %{name}+fnv-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-devel
Summary: %{summary}
@ -98,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+fs-devel %{_description}
This package contains library source intended for building other packages
which use "fs" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "fs" feature of the "%{crate}" crate.
%files -n %{name}+fs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+full-devel
Summary: %{summary}
@ -110,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+full-devel %{_description}
This package contains library source intended for building other packages
which use "full" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "full" feature of the "%{crate}" crate.
%files -n %{name}+full-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-devel
Summary: %{summary}
@ -122,11 +117,11 @@ BuildArch: noarch
%description -n %{name}+futures-core-devel %{_description}
This package contains library source intended for building other packages
which use "futures-core" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "futures-core" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-driver-devel
Summary: %{summary}
@ -134,11 +129,11 @@ BuildArch: noarch
%description -n %{name}+io-driver-devel %{_description}
This package contains library source intended for building other packages
which use "io-driver" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "io-driver" feature of the "%{crate}" crate.
%files -n %{name}+io-driver-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-std-devel
Summary: %{summary}
@ -146,11 +141,11 @@ BuildArch: noarch
%description -n %{name}+io-std-devel %{_description}
This package contains library source intended for building other packages
which use "io-std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "io-std" feature of the "%{crate}" crate.
%files -n %{name}+io-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-util-devel
Summary: %{summary}
@ -158,11 +153,11 @@ BuildArch: noarch
%description -n %{name}+io-util-devel %{_description}
This package contains library source intended for building other packages
which use "io-util" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "io-util" feature of the "%{crate}" crate.
%files -n %{name}+io-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+iovec-devel
Summary: %{summary}
@ -170,11 +165,11 @@ BuildArch: noarch
%description -n %{name}+iovec-devel %{_description}
This package contains library source intended for building other packages
which use "iovec" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "iovec" feature of the "%{crate}" crate.
%files -n %{name}+iovec-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
@ -182,11 +177,11 @@ BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages
which use "lazy_static" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
@ -194,11 +189,11 @@ BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
@ -206,11 +201,11 @@ BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages
which use "macros" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+memchr-devel
Summary: %{summary}
@ -218,11 +213,11 @@ BuildArch: noarch
%description -n %{name}+memchr-devel %{_description}
This package contains library source intended for building other packages
which use "memchr" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "memchr" feature of the "%{crate}" crate.
%files -n %{name}+memchr-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mio-devel
Summary: %{summary}
@ -230,11 +225,11 @@ BuildArch: noarch
%description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages
which use "mio" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "mio" feature of the "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mio-uds-devel
Summary: %{summary}
@ -242,11 +237,11 @@ BuildArch: noarch
%description -n %{name}+mio-uds-devel %{_description}
This package contains library source intended for building other packages
which use "mio-uds" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "mio-uds" feature of the "%{crate}" crate.
%files -n %{name}+mio-uds-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
@ -254,11 +249,11 @@ BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages
which use "net" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+num_cpus-devel
Summary: %{summary}
@ -266,11 +261,11 @@ BuildArch: noarch
%description -n %{name}+num_cpus-devel %{_description}
This package contains library source intended for building other packages
which use "num_cpus" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "num_cpus" feature of the "%{crate}" crate.
%files -n %{name}+num_cpus-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking_lot-devel
Summary: %{summary}
@ -278,11 +273,11 @@ BuildArch: noarch
%description -n %{name}+parking_lot-devel %{_description}
This package contains library source intended for building other packages
which use "parking_lot" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "parking_lot" feature of the "%{crate}" crate.
%files -n %{name}+parking_lot-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+process-devel
Summary: %{summary}
@ -290,11 +285,11 @@ BuildArch: noarch
%description -n %{name}+process-devel %{_description}
This package contains library source intended for building other packages
which use "process" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "process" feature of the "%{crate}" crate.
%files -n %{name}+process-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rt-core-devel
Summary: %{summary}
@ -302,11 +297,11 @@ BuildArch: noarch
%description -n %{name}+rt-core-devel %{_description}
This package contains library source intended for building other packages
which use "rt-core" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rt-core" feature of the "%{crate}" crate.
%files -n %{name}+rt-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rt-threaded-devel
Summary: %{summary}
@ -314,11 +309,11 @@ BuildArch: noarch
%description -n %{name}+rt-threaded-devel %{_description}
This package contains library source intended for building other packages
which use "rt-threaded" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rt-threaded" feature of the "%{crate}" crate.
%files -n %{name}+rt-threaded-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rt-util-devel
Summary: %{summary}
@ -326,11 +321,11 @@ BuildArch: noarch
%description -n %{name}+rt-util-devel %{_description}
This package contains library source intended for building other packages
which use "rt-util" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rt-util" feature of the "%{crate}" crate.
%files -n %{name}+rt-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-devel
Summary: %{summary}
@ -338,11 +333,11 @@ BuildArch: noarch
%description -n %{name}+signal-devel %{_description}
This package contains library source intended for building other packages
which use "signal" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "signal" feature of the "%{crate}" crate.
%files -n %{name}+signal-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-hook-registry-devel
Summary: %{summary}
@ -350,11 +345,11 @@ BuildArch: noarch
%description -n %{name}+signal-hook-registry-devel %{_description}
This package contains library source intended for building other packages
which use "signal-hook-registry" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "signal-hook-registry" feature of the "%{crate}" crate.
%files -n %{name}+signal-hook-registry-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slab-devel
Summary: %{summary}
@ -362,11 +357,11 @@ BuildArch: noarch
%description -n %{name}+slab-devel %{_description}
This package contains library source intended for building other packages
which use "slab" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "slab" feature of the "%{crate}" crate.
%files -n %{name}+slab-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stream-devel
Summary: %{summary}
@ -374,11 +369,11 @@ BuildArch: noarch
%description -n %{name}+stream-devel %{_description}
This package contains library source intended for building other packages
which use "stream" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sync-devel
Summary: %{summary}
@ -386,11 +381,11 @@ BuildArch: noarch
%description -n %{name}+sync-devel %{_description}
This package contains library source intended for building other packages
which use "sync" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "sync" feature of the "%{crate}" crate.
%files -n %{name}+sync-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tcp-devel
Summary: %{summary}
@ -398,11 +393,11 @@ BuildArch: noarch
%description -n %{name}+tcp-devel %{_description}
This package contains library source intended for building other packages
which use "tcp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tcp" feature of the "%{crate}" crate.
%files -n %{name}+tcp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test-util-devel
Summary: %{summary}
@ -410,11 +405,11 @@ BuildArch: noarch
%description -n %{name}+test-util-devel %{_description}
This package contains library source intended for building other packages
which use "test-util" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "test-util" feature of the "%{crate}" crate.
%files -n %{name}+test-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
@ -422,11 +417,11 @@ BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages
which use "time" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-macros-devel
Summary: %{summary}
@ -434,11 +429,11 @@ BuildArch: noarch
%description -n %{name}+tokio-macros-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-macros" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio-macros" feature of the "%{crate}" crate.
%files -n %{name}+tokio-macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-devel
Summary: %{summary}
@ -446,11 +441,11 @@ BuildArch: noarch
%description -n %{name}+tracing-devel %{_description}
This package contains library source intended for building other packages
which use "tracing" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tracing" feature of the "%{crate}" crate.
%files -n %{name}+tracing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+udp-devel
Summary: %{summary}
@ -458,11 +453,11 @@ BuildArch: noarch
%description -n %{name}+udp-devel %{_description}
This package contains library source intended for building other packages
which use "udp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "udp" feature of the "%{crate}" crate.
%files -n %{name}+udp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uds-devel
Summary: %{summary}
@ -470,11 +465,11 @@ BuildArch: noarch
%description -n %{name}+uds-devel %{_description}
This package contains library source intended for building other packages
which use "uds" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "uds" feature of the "%{crate}" crate.
%files -n %{name}+uds-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (tokio-0.2.24.crate) = 3d4a8175e44fbd28004a8c9c8e779e7ef147b0bb87e22950bfc4022eb840d0ae08159191d6487a64ecae1c4289238c8cd2839e9bc90c4b223ab1200bb8ba4a5e
SHA512 (tokio-0.2.25.crate) = 19b8d46a81230be0a06d6354c2775b20fe0c108b4c504f5fe798952bf84f8ecfd9fd149ba899ee67a1158e1b0ea9eab49f6249a655eb0ab1cf418c0097b30705

@ -1,5 +1,5 @@
--- tokio-0.2.24/Cargo.toml 2020-12-09T16:58:42+00:00
+++ tokio-0.2.24/Cargo.toml 2021-01-11T19:04:14.245732+00:00
--- tokio-0.2.25/Cargo.toml 2021-01-28T14:36:45+00:00
+++ tokio-0.2.25/Cargo.toml 2023-05-22T19:17:34.570877+00:00
@@ -107,11 +107,11 @@
io-util = ["memchr"]
macros = ["tokio-macros"]
@ -14,7 +14,17 @@
stream = ["futures-core"]
sync = ["fnv"]
tcp = ["io-driver", "iovec"]
@@ -133,11 +133,3 @@
@@ -119,9 +119,6 @@
time = ["slab"]
udp = ["io-driver"]
uds = ["io-driver", "mio-uds", "libc"]
-[target."cfg(loom)".dev-dependencies.loom]
-version = "0.3.5"
-features = ["futures", "checkpoint"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.42"
optional = true
@@ -133,11 +130,3 @@
[target."cfg(unix)".dependencies.signal-hook-registry]
version = "1.1.1"
optional = true
Loading…
Cancel
Save