Update to version 0.5.2; Fixes RHBZ#2300202

epel10 imports/epel10/rust-tokio-socks-0.5.2-1.el10
Fabio Valentini 7 months ago
parent dc402d77cc
commit fb6b687113
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/tokio-socks-0.2.2.crate /tokio-socks-0.2.2.crate
/tokio-socks-0.3.0.crate /tokio-socks-0.3.0.crate
/tokio-socks-0.5.1.crate /tokio-socks-0.5.1.crate
/tokio-socks-0.5.2.crate

@ -1,19 +1,22 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 26
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate tokio-socks %global crate tokio-socks
Name: rust-tokio-socks Name: rust-tokio-socks
Version: 0.5.1 Version: 0.5.2
Release: %autorelease Release: %autorelease
Summary: Asynchronous SOCKS proxy support for Rust Summary: Asynchronous SOCKS proxy support for Rust
License: MIT License: MIT
URL: https://crates.io/crates/tokio-socks URL: https://crates.io/crates/tokio-socks
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop smol dev-dependency which is only used by disabled integration tests
Patch: tokio-socks-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Asynchronous SOCKS proxy support for Rust.} Asynchronous SOCKS proxy support for Rust.}
@ -47,6 +50,30 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-io-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-io" feature of the "%{crate}" crate.
%files -n %{name}+futures-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tor-devel %package -n %{name}+tor-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -60,7 +87,7 @@ use the "tor" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -0,0 +1,9 @@
[package]
cargo-toml-patch-comments = [
"drop smol dev-dependency which is only used by disabled integration tests",
]
[tests]
run = ["lib", "doc"]
comments = ["integration tests require internet access"]

@ -1 +1 @@
SHA512 (tokio-socks-0.5.1.crate) = dc0ea053d11935646df436d19a653d18c7a495af1dd8dd0c02696dceabfa5b6e91f370072dae426848915f91c95f7c37a1f3835256e3e23b144b9380210fca2d SHA512 (tokio-socks-0.5.2.crate) = ee0704ae63ccf65715bed2bb1b27f92042016e2cf4ea7c2dbb3799e60d068ab9a541ab3bf1a55523d8391351430b54c93829cb54f7290f47ee949e826c98342f

@ -0,0 +1,12 @@
--- tokio-socks-0.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-socks-0.5.2/Cargo.toml 2024-07-28T12:12:39.491368+00:00
@@ -115,9 +115,6 @@
[dev-dependencies.once_cell]
version = "1.2.0"
-[dev-dependencies.smol]
-version = "2.0.0"
-
[dev-dependencies.tokio]
version = "1.0"
features = [
Loading…
Cancel
Save