Update to version 0.26.1; Fixes RHBZ#2330643

epel10 imports/epel10/rust-tokio-rustls-0.26.1-1.el10
Fabio Valentini 3 months ago
parent 5e3ce2ccc1
commit ecc99beb36
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -6,3 +6,4 @@
/tokio-rustls-0.24.1.crate
/tokio-rustls-0.25.0.crate
/tokio-rustls-0.26.0.crate
/tokio-rustls-0.26.1.crate

@ -1,15 +1,14 @@
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate tokio-rustls
Name: rust-tokio-rustls
Version: 0.26.0
Version: 0.26.1
Release: %autorelease
Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/tokio-rustls
Source: %{crates_source}
@ -116,7 +115,21 @@ use the "tls12" feature of the "%{crate}" crate.
%check
# * skip tests that require internet access
# * skip tests that fail due to expired certificates
%cargo_test -- -- --exact --skip common::test_stream::stream_handshake_regression_issues_77 --skip test_modern --skip test_tls12 --skip test_tls12_vectored --skip test_modern_vectored --skip common::test_stream::stream_bad --skip common::test_stream::stream_buffered_handshake --skip common::test_stream::stream_eof --skip common::test_stream::stream_good --skip common::test_stream::stream_good_vectored --skip common::test_stream::stream_handshake --skip pass --skip test_lazy_config_acceptor
%{cargo_test -- -- --exact %{shrink:
--skip common::test_stream::stream_handshake_regression_issues_77
--skip test_modern
--skip test_tls12
--skip test_tls12_vectored
--skip test_modern_vectored
--skip common::test_stream::stream_bad
--skip common::test_stream::stream_buffered_handshake
--skip common::test_stream::stream_eof
--skip common::test_stream::stream_good
--skip common::test_stream::stream_good_vectored
--skip common::test_stream::stream_handshake
--skip pass
--skip test_lazy_config_acceptor
}}
%endif
%changelog

@ -1 +1 @@
SHA512 (tokio-rustls-0.26.0.crate) = 101f2083e04feffec48204388c4be3d51fd6dc45bdd04bb75bdfaba48cbdd89529e14dda194ef45b2d78530cc74f128a763fb09165a52d738eb17adff7c56664
SHA512 (tokio-rustls-0.26.1.crate) = 0cee6b356ebc4be05c484d459ac457280f41401093ca942cc61a6e6514dd4a48b1cc921f7dc02f9c8bc34b751d4d40d6d4768b21193d5a12c38ebd140bad4896

@ -1,6 +1,6 @@
--- tokio-rustls-0.26.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-rustls-0.26.0/Cargo.toml 2024-06-28T09:37:31.568922+00:00
@@ -63,15 +63,12 @@
--- tokio-rustls-0.26.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-rustls-0.26.1/Cargo.toml 2024-12-09T19:53:04.387605+00:00
@@ -90,15 +90,12 @@
version = "0.26"
[features]

Loading…
Cancel
Save