Update to version 0.24.1; Fixes RHBZ#2183492

epel10
Fabio Valentini 2 years ago
parent df5a2ab5b0
commit e155c920f5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/tokio-rustls-0.22.0.crate
/tokio-rustls-0.23.4.crate
/tokio-rustls-0.24.1.crate

@ -4,8 +4,11 @@
%global crate tokio-rustls
# compile and run tests only on supported architectures
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
Name: rust-tokio-rustls
Version: 0.23.4
Version: 0.24.1
Release: %autorelease
Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
@ -13,12 +16,6 @@ Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
License: MIT OR Apache-2.0
URL: https://crates.io/crates/tokio-rustls
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump rustls-pemfile dev-dependency from 0.2 to 1.0
Patch: tokio-rustls-fix-metadata.diff
# ring is not available on ppc64le and s390x
ExcludeArch: ppc64le s390x
BuildRequires: rust-packaging >= 21
@ -90,6 +87,18 @@ use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+secret_extraction-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+secret_extraction-devel %{_description}
This package contains library source intended for building other packages which
use the "secret_extraction" feature of the "%{crate}" crate.
%files -n %{name}+secret_extraction-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tls12-devel
Summary: %{summary}
BuildArch: noarch
@ -110,16 +119,19 @@ use the "tls12" feature of the "%{crate}" crate.
%cargo_generate_buildrequires
%build
%ifarch %{supported_arches}
%cargo_build
%endif
%install
%cargo_install
%if %{with check}
%ifarch %{supported_arches}
%check
# * skip tests that require an internet connection
# * skip tests that fail due to expired certificates
%cargo_test -- -- --skip common::test_stream::stream --skip test_modern --skip test_tls12 --skip pass --skip test_lazy_config_acceptor
%cargo_test -- -- --skip test_modern --skip test_tls12
%endif
%endif
%changelog

@ -0,0 +1,6 @@
[DEFAULT]
supported-arches =
x86_64
%{ix86}
aarch64
%{arm}

@ -1 +1 @@
SHA512 (tokio-rustls-0.23.4.crate) = 92d9f5f94f8a81bb12e5923e08e9e185340351342ed167f23a9855d0c2e77089ae882c0c24faccfbf3c8f1033589a76281da42824e8447ce1b56c7a383f38b13
SHA512 (tokio-rustls-0.24.1.crate) = 93098f34d117107214e2e80e0e6c030423850ba160d1858b5149c165643700d308dacef7723e45b79fc911ba13bc1bf363c89ccac047cc6636e48a9a5a9502fa

@ -1,11 +0,0 @@
--- tokio-rustls-0.23.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-rustls-0.23.4/Cargo.toml 2023-03-18T21:37:39.147173+00:00
@@ -43,7 +43,7 @@
version = "1"
[dev-dependencies.rustls-pemfile]
-version = "0.2.1"
+version = "1.0"
[dev-dependencies.tokio]
version = "1.0"
Loading…
Cancel
Save